summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-07-16 23:54:58 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 00:10:47 +0200
commit074814fe575ebf36049a26351cc7853967ceb0ae (patch)
tree8a1d1b918f3993d3d6eea87e1044804d48c83544 /gnu/packages/password-utils.scm
parent9a622827559b223cc6b48733a82c74ce14a29bab (diff)
downloadguix-patches-074814fe575ebf36049a26351cc7853967ceb0ae.tar
guix-patches-074814fe575ebf36049a26351cc7853967ceb0ae.tar.gz
gnu: keepassxc: Set QT_PLUGIN_PATH.
* gnu/packages/password-utils.scm (keepassxc): Wrap program to set QT_PLUGIN_PATH for svg icons to show properly.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 0dffffd036..ee4d088501 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -133,7 +133,19 @@ human.")
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DWITH_XC_ALL=YES"
- "-DWITH_XC_UPDATECHECK=NO")))
+ "-DWITH_XC_UPDATECHECK=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-bin
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/keepassxc")
+ `("QT_PLUGIN_PATH" ":" prefix
+ ,(map (lambda (label)
+ (string-append (assoc-ref inputs label)
+ "/lib/qt5/plugins"))
+ '("qtbase" "qtsvg")))))
+ #t)))))
(native-inputs
`(("asciidoctor" ,ruby-asciidoctor)
("qttools" ,qttools)))