summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-10-15 10:39:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-10-15 10:39:33 +0300
commitd623ece56624fd7d611cdaf42f728b21d89fec5c (patch)
treebde903f1a5af3b1625eb3c82349be2bbbf6db129 /gnu/packages/parallel.scm
parentec2a8f602ee0fd2fac2210eeae6d1da091bb47e4 (diff)
downloadguix-patches-d623ece56624fd7d611cdaf42f728b21d89fec5c.tar
guix-patches-d623ece56624fd7d611cdaf42f728b21d89fec5c.tar.gz
gnu: slurm: Re-arrange package inputs.
* gnu/packages/parallel.scm (slurm)[inputs]: Move expect, perl, python-wrapper from here... [native-inputs]: ... to here.
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 585be21607..b600a1e5b2 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -140,19 +140,19 @@ and they are executed on lists of files, hosts, users or other items.")
#t))))
;; FIXME: More optional inputs could be added,
;; in particular mysql and gtk+.
- (inputs `(("expect" ,expect)
- ("freeipmi" ,freeipmi)
+ (inputs `(("freeipmi" ,freeipmi)
("hwloc" ,hwloc-2 "lib")
("json-c" ,json-c)
("linux-pam" , linux-pam)
("munge" ,munge)
("numactl" ,numactl)
- ("perl" ,perl)
- ("python" ,python-wrapper)
("readline" ,readline)))
(native-inputs
`(("autoconf" ,autoconf)
- ("pkg-config" ,pkg-config)))
+ ("expect" ,expect)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
(build-system gnu-build-system)
(arguments
`(#:configure-flags