summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-28 10:17:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-28 10:18:07 +0200
commitd027637026f8aedabe5a0ceeb2c74d1d77d0109b (patch)
tree6458af8ec6d4e075fa3a8d0e85fd5faabf941d88 /gnu/packages/parallel.scm
parentffd5bc9600db50d5ffa7347f1aee8ee106db732d (diff)
downloadguix-patches-d027637026f8aedabe5a0ceeb2c74d1d77d0109b.tar
guix-patches-d027637026f8aedabe5a0ceeb2c74d1d77d0109b.tar.gz
gnu: slurm: Link plugins with libslurm.
* gnu/packages/parallel.scm (slurm)[arguments]: Add phase patch-plugin-linker-flags to link plugins with libslurm; run autoconf phase after this new phase.
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index dcd28c792b..17e2a7f7fe 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -198,7 +198,12 @@ execution is also possible.")
,@(if (target-64bit?) '() '("--enable-deprecated")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autoconf
+ (add-after 'unpack 'patch-plugin-linker-flags
+ (lambda _
+ (substitute* (find-files "src/plugins/" "Makefile.in")
+ (("_la_LDFLAGS = ")
+ "_la_LDFLAGS = ../../../api/libslurm.la "))))
+ (add-after 'patch-plugin-linker-flags 'autoconf
(lambda _ (invoke "autoconf"))) ;configure.ac was patched
(add-after 'install 'install-libpmi
(lambda _