summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-05-18 22:57:43 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-28 23:04:44 +0200
commit9d439e3ba05e99f33cf95ee3c3f8729caed4791e (patch)
treefe14ef0cb661f42aadf7e422f57abc0cd0bdc06a /gnu/packages/parallel.scm
parentca1caf9cf157df58dd7b080ad7795b6cf11e47bf (diff)
downloadguix-patches-9d439e3ba05e99f33cf95ee3c3f8729caed4791e.tar
guix-patches-9d439e3ba05e99f33cf95ee3c3f8729caed4791e.tar.gz
gnu: Add xjobs.
* gnu/packages/parallel.scm (xjobs): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index d950fa9014..1108d6f457 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages freeipmi)
#:use-module (gnu packages linux)
#:use-module (gnu packages mpi)
@@ -135,6 +136,32 @@ execution is also possible.")
(home-page "https://github.com/leahneukirchen/xe")
(license license:public-domain)))
+(define-public xjobs
+ (package
+ (name "xjobs")
+ (version "20200726")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.maier-komor.de/xjobs/xjobs-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0ay6gn43pnm7r1jamwgpycl67bjg5n87ncl27jb01w2x6x70z0i3"))))
+ (build-system gnu-build-system)
+ (arguments `(#:tests? #f)) ;; No tests
+ (native-inputs
+ `(("flex" ,flex)
+ ("which" ,which)))
+ (home-page "http://www.maier-komor.de/xjobs.html")
+ (synopsis
+ "Parallel execution of jobs with several useful options")
+ (description
+ "xjobs reads job descriptions line by line and executes them in
+parallel. It limits the number of parallel executing jobs and starts new jobs
+when jobs finish.")
+ (license license:gpl2+)))
+
(define-public slurm
(package
(name "slurm")