summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-17 19:18:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-18 04:26:43 +0100
commit4ff22ec3b16a90b140721aa10c94c595ccb2c390 (patch)
tree08c0dd5a03c3ae1802947d0ff5aa39c752c15af4 /gnu/packages/parallel.scm
parent5d5ad3da881566c2cfe01bd70e6d759f241fc73a (diff)
downloadguix-patches-4ff22ec3b16a90b140721aa10c94c595ccb2c390.tar
guix-patches-4ff22ec3b16a90b140721aa10c94c595ccb2c390.tar.gz
gnu: slurm: Update to 17.11.2.
* gnu/packages/parallel.scm (slurm): Update to 17.11.2. [source]: Replace patch with less fragile SUBSTITUTE* in a snippet. [arguments]: Rename ‘autogen’ phase to ‘autoconf’. Use INVOKE. * gnu/packages/patches/slurm-configure-remove-nonfree-contribs.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index cc6542e853..2ec866f5f6 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -93,7 +94,7 @@ and they are executed on lists of files, hosts, users or other items.")
(define-public slurm
(package
(name "slurm")
- (version "16.05.11")
+ (version "17.11.2")
(source (origin
(method url-fetch)
(uri (string-append
@@ -101,12 +102,12 @@ and they are executed on lists of files, hosts, users or other items.")
version ".tar.bz2"))
(sha256
(base32
- "0c63mvh13wsp6jlydaz98v35iwg53mk94ynpx9dqn2z4gl53k5y7"))
- (patches (search-patches
- "slurm-configure-remove-nonfree-contribs.patch"))
+ "18yakb8kmhb16n0cv3zhjv8ahvsk9p0max8mmr2flb2c65fawks6"))
(modules '((guix build utils)))
(snippet
'(begin
+ (substitute* "configure.ac"
+ (("^[[:space:]]+contribs/.*$") ""))
(delete-file-recursively "contribs")
#t))))
;; FIXME: More optional inputs could be added,
@@ -136,8 +137,8 @@ and they are executed on lists of files, hosts, users or other items.")
(string-append "--with-ssl=" (assoc-ref %build-inputs "openssl")))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autogen
- (lambda _ (zero? (system* "autoconf"))))))) ; configure.ac was patched
+ (add-after 'unpack 'autoconf
+ (lambda _ (invoke "autoconf")))))) ; configure.ac was patched
(home-page "http://slurm.schedmd.com/")
(synopsis "Workload manager for cluster computing")
(description