summaryrefslogtreecommitdiff
path: root/gnu/packages/parallel.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2021-07-29 16:11:26 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-29 21:54:55 +0200
commit065d45e8a1c3af31889df53d6feb49973814009c (patch)
tree8b4975cc13119d5f241dfd1a23ab54afae0a3e7c /gnu/packages/parallel.scm
parent4c5ad827808f6c9964c05c9777d02b200fa619bb (diff)
downloadguix-patches-065d45e8a1c3af31889df53d6feb49973814009c.tar
guix-patches-065d45e8a1c3af31889df53d6feb49973814009c.tar.gz
gnu: Add Psimd.
* gnu/packages/parallel.scm (psimd): New variable.
Diffstat (limited to 'gnu/packages/parallel.scm')
-rw-r--r--gnu/packages/parallel.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index b5914fdffa..ca8be00cea 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -442,3 +442,27 @@ features.")
obtain information about the CPU being used: supported instruction set,
processor name, cache information, and topology information.")
(license license:bsd-2))))
+
+(define-public psimd
+ ;; There is currently no tag in this repo.
+ (let ((commit "072586a71b55b7f8c584153d223e95687148a900")
+ (version "0.0")
+ (revision "1"))
+ (package
+ (name "psimd")
+ (version (git-version version revision commit))
+ (home-page "https://github.com/Maratyszcza/Psimd")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16mslhvqs0gpqbg7kkq566a8gkn58cgjpqca8ljj9qcv5mk9apwm"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;there are no tests
+ (synopsis "Portable 128-bit SIMD intrinsics")
+ (description
+ "This header-only C++ library provides a portable interface to
+single-instruction multiple-data (SIMD) intrinsics.")
+ (license license:expat))))