summaryrefslogtreecommitdiff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-05-15 14:57:34 -0500
committerDanny Milosavljevic <dannym@scratchpost.org>2020-05-19 12:59:40 +0200
commit969811ad0e51adcbf503e38d9c9265814e3c2e27 (patch)
tree55cf74aee92c0d3b1cf35ba01e10aee8c5cc7860 /gnu/packages/pantheon.scm
parent11491e1b1bdac1255f1f529f13b8eecabdb7cc66 (diff)
downloadguix-patches-969811ad0e51adcbf503e38d9c9265814e3c2e27.tar
guix-patches-969811ad0e51adcbf503e38d9c9265814e3c2e27.tar.gz
gnu: Add pantheon-calculator.
* gnu/packages/pantheon.scm (pantheon-calculator): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 8c5c1634ee..306a1d892d 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages pantheon)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -65,3 +66,44 @@
things, it provides complex widgets and convenience functions designed for use
in apps built for the Pantheon desktop.")
(license license:lgpl3+)))
+
+(define-public pantheon-calculator
+ (package
+ (name "pantheon-calculator")
+ (version "1.5.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/calculator.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1csxsr2c8qvl97xz9ahwn91z095nzgr0i1mbcb1spljll2sr9lkj"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-schema-cache-generation
+ (lambda _
+ (setenv "DESTDIR" "/")
+ #t)))))
+ (inputs
+ `(("granite" ,granite)
+ ("glib" ,glib)
+ ("gtk" ,gtk+)
+ ("libgee" ,libgee)))
+ (native-inputs
+ `(("cmake" ,cmake)
+ ("glib:bin" ,glib "bin") ; for glib-compile-schemas
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (home-page "https://github.com/elementary/calculator")
+ (synopsis "Desktop calculator")
+ (description "Calculator is an application for performing simple
+arithmetic. It is the default calculator application in the Pantheon
+desktop.")
+ (license license:gpl3)))