summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-02-11 20:21:39 +0000
committerLeo Famulari <leo@famulari.name>2019-02-13 18:52:19 -0500
commit706460a35754a47bf832a40de4f22271e7088226 (patch)
treefc5f326ebf2634155cf475d39bacdf220eb013cc /gnu/packages/package-management.scm
parent69c15ad8a46c8e5f319a73ee5891bcd1bf0600c5 (diff)
downloadguix-patches-706460a35754a47bf832a40de4f22271e7088226.tar
guix-patches-706460a35754a47bf832a40de4f22271e7088226.tar.gz
gnu: Add trydiffoscope.
* gnu/packages/package-management (trydiffoscope): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index af9667cd91..eff8d5c3fd 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -606,6 +607,55 @@ various binary formats into more human readable forms to compare them. It can
compare two tarballs, ISO images, or PDFs just as easily.")
(license license:gpl3+)))
+(define-public trydiffoscope
+ (package
+ (name "trydiffoscope")
+ (version "67.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((share (string-append (assoc-ref outputs "out") "/share/")))
+ (mkdir-p (string-append share "/man/man1/" ))
+ (invoke "rst2man.py"
+ "trydiffoscope.1.rst"
+ (string-append share "/man/man1/trydiffoscope.1"))
+ (mkdir-p (string-append share "/doc/" ,name "-" ,version))
+ (install-file "./README.rst"
+ (string-append share "/doc/" ,name "-" ,version)))
+ #t)))))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
+ (native-inputs
+ `(("gzip" ,gzip)
+ ("python-docutils" ,python-docutils)))
+ (build-system python-build-system)
+ (home-page "https://try.diffoscope.org")
+ (synopsis "Client for remote diffoscope service")
+ (description "This is a client for the @url{https://try.diffoscope.org,
+remote diffoscope service}.
+
+Diffoscope tries to get to the bottom of what makes files or directories
+different. It recursively unpacks archives of many kinds and transforms
+various binary formats into more human readable forms to compare them. It can
+compare two tarballs, ISO images, or PDFs just as easily.
+
+Results are displayed by default, stored as local text or html files, or made
+available via a URL on @url{https://try.diffoscope.org}. Results stored on the
+server are purged after 30 days.")
+ (license license:gpl3+)))
+
(define-public python-anaconda-client
(package
(name "python-anaconda-client")