summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-02-16 14:03:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-16 14:09:22 +0100
commit598ea80f84922908245c47b03d22cfdeac813676 (patch)
tree8be59e196110f3d553dc932049a7979d620b1d95 /gnu/packages/package-management.scm
parent3c6aca4232d1a3638ec962bc7afe9121626c43ec (diff)
downloadguix-patches-598ea80f84922908245c47b03d22cfdeac813676.tar
guix-patches-598ea80f84922908245c47b03d22cfdeac813676.tar.gz
gnu: gwl: Update to 0.2.0.
* gnu/packages/package-management.scm (gwl): Update to 0.2.0. [source]: Fetch from gnu.org. [native-inputs]: Add texinfo and graphviz. [propagated-inputs]: Add guile-gcrypt, guile-pfds, guile-syntax-highlight, and guile-wisp. [home-page]: Use workflows.guix.info. [description]: Use official project description.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm29
1 files changed, 18 insertions, 11 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 422d4f1959..09888ca9e2 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
@@ -788,29 +788,36 @@ written entirely in Python.")))
(define-public gwl
(package
(name "gwl")
- (version "0.1.1")
+ (version "0.2.0")
(source (origin
(method url-fetch)
- (uri (string-append "https://www.guixwl.org/releases/gwl-"
- version ".tar.gz"))
+ (uri (string-append "mirror://gnu/gwl/gwl-" version ".tar.gz"))
(sha256
(base32
- "06pm967mq1wyggx7l0nfapw5s0k5qc5r9lawk2v3db868br779a7"))))
+ "0db1nvy6qzhj9kv834vrlxw7gqv3lih1n4hv5zac1zjmb61ll915"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ("graphviz" ,graphviz)))
(inputs
`(("guile" ,guile-2.2)))
(propagated-inputs
`(("guix" ,guix)
- ("guile-commonmark" ,guile-commonmark)))
- (home-page "https://www.guixwl.org")
+ ("guile-commonmark" ,guile-commonmark)
+ ("guile-gcrypt" ,guile-gcrypt)
+ ("guile-pfds" ,guile-pfds)
+ ("guile-syntax-highlight" ,guile-syntax-highlight)
+ ("guile-wisp" ,guile-wisp)))
+ (home-page "https://workflows.guix.info")
(synopsis "Workflow management extension for GNU Guix")
- (description "This project provides two subcommands to GNU Guix and
-introduces two record types that provide a workflow management extension built
-on top of GNU Guix.")
+ (description "The @dfn{Guix Workflow Language} (GWL) provides an
+extension to GNU Guix's declarative language for package management to
+automate the execution of programs in scientific workflows. The GWL
+can use process engines to integrate with various computing
+environments.")
;; The Scheme modules in guix/ and gnu/ are licensed GPL3+,
;; the web interface modules in gwl/ are licensed AGPL3+,
;; and the fonts included in this package are licensed OFL1.1.