summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-21 23:01:35 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:51:06 +0200
commit2111a4eee7441213156e9df04dd141cf19d91fdc (patch)
treece927cb8fceca2bbefa7a6b75eabab41ed6cb79d /gnu/packages/package-management.scm
parent84de0e317511515d310ca54d90bbd7996babe0fc (diff)
downloadguix-patches-2111a4eee7441213156e9df04dd141cf19d91fdc.tar
guix-patches-2111a4eee7441213156e9df04dd141cf19d91fdc.tar.gz
gnu: conan: Update to 1.50.0.
* gnu/packages/package-management.scm (conan): Update to 1.50.0. [arguments]<phases>{check}: Add another test to be skipped, adjust comment.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 01abd98d65..0469c73ff5 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1152,7 +1152,7 @@ written entirely in Python.")
(define-public conan
(package
(name "conan")
- (version "1.47.0")
+ (version "1.50.0")
(source
(origin
(method git-fetch) ;no tests in PyPI archive
@@ -1162,7 +1162,7 @@ written entirely in Python.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zs2xb22rsy5fsc0fd7c95vrx1mfz7vasyg1lqkzyfimvn5zah6n"))))
+ "1jjrinz5wkcxfvwdpldrv4h7vacdyz88cc4af5vi3sdnjra0i0m5"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1231,8 +1231,9 @@ written entirely in Python.")
;; This one fails for unknown reasons (see:
;; https://github.com/conan-io/conan/issues/9671).
"and not test_build "
- ;; This test expects the 'apt' command to be available.
+ ;; These tests expect the 'apt' command to be available.
"and not test_apt_check "
+ "and not test_apt_install_substitutes "
(if (not (string-prefix? "x86_64" system))
;; These tests either assume the machine is
;; x86_64, or require a cross-compiler to target