summaryrefslogtreecommitdiff
path: root/gnu/packages/ots.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-21 20:57:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-21 20:58:52 +0200
commit8ea71f20050f9faf1f1faba4b02216436aee783d (patch)
tree2e9d2a76de7d496407a728eb054a58392026596f /gnu/packages/ots.scm
parentb1d3e0a93bf12a29fc43144156a181f409e6b362 (diff)
downloadguix-patches-8ea71f20050f9faf1f1faba4b02216436aee783d.tar
guix-patches-8ea71f20050f9faf1f1faba4b02216436aee783d.tar.gz
gnu: ots: Use 'modify-phases' syntax.
* gnu/packages/ots.scm (ots)[arguments]: Use 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/ots.scm')
-rw-r--r--gnu/packages/ots.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/ots.scm b/gnu/packages/ots.scm
index d02a92768b..73dd5e4832 100644
--- a/gnu/packages/ots.scm
+++ b/gnu/packages/ots.scm
@@ -53,17 +53,18 @@
;; before libots-1.la has been built.
'(#:parallel-build? #f
- #:phases (alist-cons-after
- 'configure 'set-shared-lib-extension
- (lambda _
- ;; For some reason, the 'libtool' script (from Libtool
- ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
- ;; 'shrext' for the shared library file name extension.
- ;; This leads to the creation of 'libots-1' instead of
- ;; 'libots-1.so'. Fix that.
- (substitute* "libtool"
- (("shrext_cmds") "shrext")))
- %standard-phases)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'set-shared-lib-extension
+ (lambda _
+ ;; For some reason, the 'libtool' script (from Libtool
+ ;; 1.5.2, Debian variant) sets 'shrext_cmds' instead of
+ ;; 'shrext' for the shared library file name extension.
+ ;; This leads to the creation of 'libots-1' instead of
+ ;; 'libots-1.so'. Fix that.
+ (substitute* "libtool"
+ (("shrext_cmds") "shrext"))
+ #t)))))
(inputs
`(("glib" ,glib)
("popt" ,popt)