summaryrefslogtreecommitdiff
path: root/gnu/packages/orange.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-25 03:26:02 +0000
committerLeo Famulari <leo@famulari.name>2021-04-25 14:49:57 -0400
commitf76ffea2429ed986b56826387166bd2793db0e76 (patch)
tree680c6d3fc9e0e4ebe9a4fb0e3923f6ab09a0a249 /gnu/packages/orange.scm
parent45d80c72dc9b4f1aad1bd6e90313a73ee8a4f64a (diff)
downloadguix-patches-f76ffea2429ed986b56826387166bd2793db0e76.tar
guix-patches-f76ffea2429ed986b56826387166bd2793db0e76.tar.gz
gnu: Add python-orange-canvas-core.
* gnu/packages/orange.scm: New file. * gnu/packages/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/orange.scm')
-rw-r--r--gnu/packages/orange.scm66
1 files changed, 66 insertions, 0 deletions
diff --git a/gnu/packages/orange.scm b/gnu/packages/orange.scm
new file mode 100644
index 0000000000..fb273cbbec
--- /dev/null
+++ b/gnu/packages/orange.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages orange)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system python)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages python-web)
+ #:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages qt))
+
+(define-public python-orange-canvas-core
+ (package
+ (name "python-orange-canvas-core")
+ (version "0.1.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "orange-canvas-core" version))
+ (sha256
+ (base32 "03wav2msfm32y8zwq69v1v6qyh1ld76xla2z60avf49yhbwjgwal"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; This test fails with: RuntimeError: Event loop is closed.
+ (substitute* "orangecanvas/application/tests/test_mainwindow.py"
+ (("test_help_requests") "_test_help_requests"))
+ (setenv "HOME" "/tmp")
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (propagated-inputs
+ `(("python-anyqt" ,python-anyqt)
+ ("python-cachecontrol" ,python-cachecontrol)
+ ("python-commonmark" ,python-commonmark)
+ ("python-dictdiffer" ,python-dictdiffer)
+ ("python-docutils" ,python-docutils)
+ ("python-pyqt" ,python-pyqt)
+ ("python-qasync" ,python-qasync)
+ ("python-requests" ,python-requests)))
+ (home-page "https://github.com/biolab/orange-canvas-core")
+ (synopsis "Core component of Orange Canvas")
+ (description
+ "Orange Canvas Core is a framework for building graphical user interfaces
+for editing workflows. It is a component used to build the Orange Canvas
+data-mining application.")
+ (license license:gpl3)))