summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-20 09:53:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:34:13 +0200
commite2857167b1f49888c4c216c5735257350b3e161e (patch)
tree6b65f6d6d2e06d3336af470a67d04fb6c3d59635 /gnu/packages/openstack.scm
parentb5801efaa33af9b46274b67807d4e665b2b685c1 (diff)
downloadguix-patches-e2857167b1f49888c4c216c5735257350b3e161e.tar
guix-patches-e2857167b1f49888c4c216c5735257350b3e161e.tar.gz
gnu: Add python-os-service-types.
* gnu/packages/openstack.scm (python-os-service-types): New variable.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 0721d27dbf..e132f70832 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -251,6 +252,32 @@ to docs.openstack.org and developer.openstack.org.")
comprehensive manner.")
(license asl2.0)))
+(define-public python-os-service-types
+ (package
+ (name "python-os-service-types")
+ (version "1.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "os-service-types" version))
+ (sha256
+ (base32
+ "0v4chwr5jykkvkv4w7iaaic7gb06j6ziw7xrjlwkcf92m2ch501i"))))
+ (build-system python-build-system)
+ (arguments
+ ;; The tests are disabled to avoid a circular dependency with
+ ;; python-keystoneauth1.
+ `(#:tests? #f))
+ (native-inputs (list python-pbr))
+ (home-page "https://docs.openstack.org/os-service-types/latest/")
+ (synopsis "Library for consuming OpenStack Service Types Authority data")
+ (description "The @emph{OpenStack Service Types Authority} contains
+information about officiag OpenStack services and their historical
+service-type aliases. The data is in JSON and the latest data should always
+be used. This simple library exists to allow for easy consumption of the
+data, along with a built-in version of the data to use in case network access
+is for some reason not possible and local caching of the fetched data.")
+ (license asl2.0)))
+
(define-public python-os-testr
(package
(name "python-os-testr")