summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-20 21:49:40 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 09:38:58 +0200
commitd2dd9d1d2648b81d08f668c0a9dfc300af54d2ac (patch)
tree96ff256e07c3c0636fc000cdb7dd716f7ba6f6ba /gnu/packages/openstack.scm
parentb08a3554a4577f7fb1557f296aa189bc220e7138 (diff)
downloadguix-patches-d2dd9d1d2648b81d08f668c0a9dfc300af54d2ac.tar
guix-patches-d2dd9d1d2648b81d08f668c0a9dfc300af54d2ac.tar.gz
gnu: python-keystoneclient: Update to 5.0.0.
* gnu/packages/openstack.scm (python-keystoneclient): Update to 5.0.0. [arguments]<phases>{relax-requirements}: New phase. [propagated-inputs]: Remove python-pbr; add python-keystoneauth1. [native-inputs]: Adjust to new style. Remove python-sphinx, python-coverage, python-discover, python-hacking, python-mox3, python-oslosphinx, python-pycrypto, python-testrepository, and python-webob; add python-pbr, python-stestr, and python-testscenarios.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm54
1 files changed, 29 insertions, 25 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 5bf5983541..ebe3f39f9c 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -848,49 +848,53 @@ process of writing new clients.")
(define-public python-keystoneclient
(package
(name "python-keystoneclient")
- (version "1.8.1")
+ (version "5.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-keystoneclient" version))
(sha256
(base32
- "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
+ "0gza5fx3xl3l6vrc6pnhbzhipz1fz9h98kwxqp7mmd90pwrxll0g"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; FIXME: Many tests are failing.
+ '(#:tests? #f ; FIXME: Many tests are failing.
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "test-requirements.txt"
+ ;; unused, code-quality checks only
+ (("hacking[<>!=]" line) (string-append "# " line))
+ (("flake8-.*[<>!=]" line) (string-append "# " line))
+ (("pycodestyle[<>!=]" line) (string-append "# " line))
+ (("bandit[<>!=]" line) (string-append "# " line))
+ (("coverage[<>!=]" line) (string-append "# " line))
+ (("reno[<>!=]" line) (string-append "# " line))))))))
(native-inputs
- `(("python-sphinx" ,python-sphinx)
- ;; and some packages for the tests
- ("openssl" ,openssl)
- ("python-coverage" ,python-coverage)
- ("python-discover" ,python-discover)
- ("python-fixtures" ,python-fixtures)
- ("python-hacking" ,python-hacking)
- ("python-keyring" ,python-keyring)
- ("python-lxml" ,python-lxml)
- ("python-mock" ,python-mock)
- ("python-mox3" ,python-mox3)
- ("python-oauthlib" ,python-oauthlib)
- ("python-oslosphinx" ,python-oslosphinx)
- ("python-oslotest" ,python-oslotest)
- ("python-pycrypto" ,python-pycrypto)
- ("python-requests-mock" ,python-requests-mock)
- ("python-temptest-lib" ,python-tempest-lib)
- ("python-testrepository" ,python-testrepository)
- ("python-testresources" ,python-testresources)
- ("python-testtools" ,python-testtools)
- ("python-webob" ,python-webob)))
+ (list openssl
+ python-fixtures
+ python-keyring
+ python-lxml
+ python-mock
+ python-oauthlib
+ python-oslotest
+ python-pbr
+ python-requests-mock
+ python-stestr
+ python-tempest-lib
+ python-testresources
+ python-testscenarios
+ python-testtools))
(propagated-inputs
(list python-babel
python-debtcollector
python-iso8601
+ python-keystoneauth1
python-netaddr
python-oslo.config
python-oslo.i18n
python-oslo.serialization
python-oslo.utils
- python-pbr
python-prettytable
python-requests
python-six