summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-01-18 08:53:03 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-01-19 16:36:38 +0100
commitc8d7e063d0b576615fb481e0abc55c0aeab609b8 (patch)
tree6d9d23b6a2ce3ec6ba969f6b73028a3735365773 /gnu/packages/openstack.scm
parent7adb90311f8ce5e44c5bd1ecba28dcb26bfabebe (diff)
downloadguix-patches-c8d7e063d0b576615fb481e0abc55c0aeab609b8.tar
guix-patches-c8d7e063d0b576615fb481e0abc55c0aeab609b8.tar.gz
gnu: Add python-reno.
* gnu/packages/openstack.scm (python-reno, python-reno2): New variables.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 2500590b2f..5bb83095a0 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -19,6 +19,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages openstack)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages python)
#:use-module (gnu packages ssh)
#:use-module (gnu packages tls)
@@ -550,6 +551,47 @@ in transmittable and storable formats, such as JSON and MessagePack.")
(define-public python2-oslo.serialization
(package-with-python2 python-oslo.serialization))
+(define-public python-reno
+ (package
+ (name "python-reno")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "reno" version))
+ (sha256
+ (base32 "1i2wnn5fnm3jm5774pahg000q0lma5i913hml91bbbm2mybphndd"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'init-git
+ (lambda _
+ ;; reno expects a git repo
+ (zero? (system* "git" "init")))))))
+ (propagated-inputs
+ `(("python-babel" ,python-babel)
+ ("python-dulwich" ,python-dulwich)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-six" ,python-six)))
+ (native-inputs
+ `(("python-testtools" ,python-testtools)
+ ("python-pbr" ,python-pbr)
+ ("python-testscenarios" ,python-testscenarios)
+ ("python-testrepository" ,python-testrepository)
+ ("python-mock" ,python-mock)
+ ("python-oslotest" ,python-oslotest)
+ ("gnupg" ,gnupg)
+ ("git" ,git)))
+ (home-page "http://docs.openstack.org/developer/reno/")
+ (synopsis "Release notes manager")
+ (description "Reno is a tool for storing release notes in a git repository
+and building documentation from them.")
+ (license asl2.0)))
+
+(define-public python2-reno
+ (package-with-python2 python-reno))
+
(define-public python-oslosphinx
(package
(name "python-oslosphinx")