summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-18 22:59:33 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-19 21:56:59 -0500
commitb5b548efc51432563ea2d4fbda7b896a76c6eb95 (patch)
tree0d85f8c4001e97302a19c8cb96825fbc53724e53 /gnu/packages/openstack.scm
parent5c6c3fbd8c3685274bd557e04207f04686e3d3a4 (diff)
downloadguix-patches-b5b548efc51432563ea2d4fbda7b896a76c6eb95.tar
guix-patches-b5b548efc51432563ea2d4fbda7b896a76c6eb95.tar.gz
gnu: python-oslosphinx: Update to 4.18.0.
* gnu/packages/openstack.scm (python-oslosphinx): Update to 4.18.0. [phases]: Delete 'check replacement. Add a 'relax-requirements phase. [native-inputs]: Remove python-docutils. Add python-openstackdocstheme and python-reno. (python2-oslosphinx): Remove variable.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm24
1 files changed, 11 insertions, 13 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index eb32d90451..13b92936d0 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -617,30 +617,31 @@ and building documentation from them.")
(define-public python-oslosphinx
(package
(name "python-oslosphinx")
- (version "4.10.0")
+ (version "4.18.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "oslosphinx" version))
(sha256
(base32
- "09mxqyabi68f3s3arvdhlhq0mn38vf74jbsfcg84151hcj6czhnl"))))
+ "1xm41857vzrzjmnyi6bqirg4i5qa61v7wxcsdc4q1nzgr3ndgz5k"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (replace 'check
+ (add-after 'unpack 'relax-requirements
(lambda _
- ;; Note: Upstream tests would have also built the release notes.
- ;; That only would work if we were in a git checkout.
- ;; Therefore, we don't do it here.
- (invoke "python" "setup.py" "build_sphinx"))))))
+ (substitute* "test-requirements.txt"
+ (("hacking!=0.13.0,<0.14,>=0.12.0")
+ "hacking!=0.13.0,>=0.12.0"))
+ #t)))))
(propagated-inputs
`(("python-requests" ,python-requests)))
(native-inputs
- `(("python-pbr" ,python-pbr)
- ("python-docutils" ,python-docutils)
- ("python-hacking" ,python-hacking)
+ `(("python-hacking" ,python-hacking)
+ ("python-openstackdocstheme" ,python-openstackdocstheme)
+ ("python-pbr" ,python-pbr)
+ ("python-reno" ,python-reno)
("python-sphinx" ,python-sphinx)))
(home-page "https://www.openstack.org/")
(synopsis "OpenStack sphinx extensions and theme")
@@ -648,9 +649,6 @@ and building documentation from them.")
documentation from the OpenStack project.")
(license asl2.0)))
-(define-public python2-oslosphinx
- (package-with-python2 python-oslosphinx))
-
(define-public python-oslotest
(package
(name "python-oslotest")