summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-12 01:06:23 -0500
committerLeo Famulari <leo@famulari.name>2016-02-12 18:50:32 -0500
commit8ad4ae204f5205c1335cceff22058411a67392eb (patch)
tree45c86d8ac8d88b37c36fca37f0b009e018d5e1c9 /gnu/packages/openstack.scm
parenta14600ecfa6d4304418cda8668dfefdc2c1ce715 (diff)
downloadguix-patches-8ad4ae204f5205c1335cceff22058411a67392eb.tar
guix-patches-8ad4ae204f5205c1335cceff22058411a67392eb.tar.gz
gnu: python-wheel: Define 'python2-variant'.
* gnu/packages/python.scm (python-wheel)[properties]: New field. (python2-wheel): Use 'strip-python2-variant'. (python2-requests): Take the result of 'package-with-python2' directly. * gnu/packages/openstack.scm (python2-requests-mock): Likewise. (python2-oslosphinx): Likewise.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 9a42a91340..08a76a3695 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -304,12 +304,7 @@ portions of your testing code.")
(license asl2.0)))
(define-public python2-requests-mock
- (let ((requests-mock (package-with-python2 python-requests-mock)))
- (package (inherit requests-mock)
- (propagated-inputs
- `(("python2-requests" ,python2-requests)
- ,@(alist-delete "python-requests"
- (package-propagated-inputs requests-mock)))))))
+ (package-with-python2 python-requests-mock))
(define-public python-stevedore
(package
@@ -601,9 +596,7 @@ from the OpenStack project.")
(license asl2.0)))
(define-public python2-oslosphinx
- (let ((oslosphinx (package-with-python2 python-oslosphinx)))
- (package (inherit oslosphinx)
- (propagated-inputs `(("python2-requests" ,python2-requests))))))
+ (package-with-python2 python-oslosphinx))
(define-public python-oslotest
(package