summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-18 15:35:02 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-19 21:56:58 -0500
commit762238c4d3210b5102dbe0b03238f74d580e1c68 (patch)
treecdcf830e6591e8aebb680304d45afcbb212ba397 /gnu/packages/openstack.scm
parent2cafbf4147d31b0018583618204746424e0c2449 (diff)
downloadguix-patches-762238c4d3210b5102dbe0b03238f74d580e1c68.tar
guix-patches-762238c4d3210b5102dbe0b03238f74d580e1c68.tar.gz
gnu: Add python-cliff.
* gnu/packages/openstack.scm (python-cliff): New variable.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 57f193702a..2239c211a7 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -73,6 +73,38 @@ and runs appropriate plugins against the AST nodes. Once Bandit has finished
scanning all the files it generates a report.")
(license asl2.0)))
+(define-public python-cliff
+ (package
+ (name "python-cliff")
+ (version "3.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cliff" version))
+ (sha256
+ (base32
+ "0n8pzr0mnn9lq2mykds69ij2xrn0fsirh4ndmkx0mzydbx5niysv"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (native-inputs
+ `(("python-pbr" ,python-pbr)))
+ (propagated-inputs
+ `(("python-cmd2" ,python-cmd2)
+ ("python-prettytable" ,python-prettytable)
+ ("python-pyparsing" ,python-pyparsing)
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-bandit" ,python-bandit)
+ ("python-stevedore" ,python-stevedore)))
+ (home-page "https://opendev.org/openstack/cliff")
+ (synopsis "Framework for building command line programs")
+ (description "The @code{cliff} framework allows creating multi-level
+commands such as those of @command{subversion} and @command{git}, where the
+main program handles some basic argument parsing and then invokes a
+sub-command to do the work. It uses plugins to define sub-commands, output
+formatters, and other extensions.")
+ (license asl2.0)))
+
(define-public python-debtcollector
(package
(name "python-debtcollector")