summaryrefslogtreecommitdiff
path: root/gnu/packages/openpgp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/openpgp.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/openpgp.scm')
-rw-r--r--gnu/packages/openpgp.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/openpgp.scm b/gnu/packages/openpgp.scm
index a5b8f1b09d..40df62a6d7 100644
--- a/gnu/packages/openpgp.scm
+++ b/gnu/packages/openpgp.scm
@@ -46,8 +46,7 @@
"179b5jx3mqs9hgsj8cfwk6x8qib60kw9szk9fkz6s1gl3v83mnyx"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--enable-silent-rules")))
- (inputs `(("gmp" ,gmp)
- ("libgcrypt" ,libgcrypt)))
+ (inputs (list gmp libgcrypt))
(synopsis
"C++ library for creating secure and fair online card games")
(description
@@ -79,11 +78,7 @@ LibTMCG provides the first practical implementation of such protocols.")
'("--enable-silent-rules")
;; https://savannah.nongnu.org/bugs/?58772
#:parallel-tests? #f))
- (inputs `(("bzip2" ,bzip2)
- ("gmp" ,gmp)
- ("libgcrypt" ,libgcrypt)
- ("libtmcg" ,libtmcg)
- ("zlib" ,zlib)))
+ (inputs (list bzip2 gmp libgcrypt libtmcg zlib))
(synopsis
"Distributed Key Generation and Threshold Cryptography for OpenPGP")
(description
@@ -159,10 +154,7 @@ environments.")
("pkg-config" ,pkg-config)
("python" ,python)
("python2" ,python-2.7)))
- (inputs `(("botan" ,botan)
- ("bzip2" ,bzip2)
- ("json-c" ,json-c)
- ("zlib" ,zlib)))
+ (inputs (list botan bzip2 json-c zlib))
(synopsis
"RFC4880-compliant OpenPGP library written in C++")
(description