summaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-19 20:01:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-20 12:19:55 +0100
commitcbc6a28b6781494f458966498517092fba395f94 (patch)
treedd98cdc2c566df330577416ae79c4f90a398d913 /gnu/packages/openldap.scm
parent3d7a7b1dd63aa6de5b499eb6d3e28bc4b4543a0f (diff)
downloadguix-patches-cbc6a28b6781494f458966498517092fba395f94.tar
guix-patches-cbc6a28b6781494f458966498517092fba395f94.tar.gz
gnu: 389-ds-base: Update to 1.4.0.21.
* gnu/packages/openldap.scm (389-ds-base): Update to 1.4.0.21. [arguments]: Add phase "fix-includes". [inputs]: Add cracklib.
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 368a953cb5..c3075b4d59 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -36,6 +36,7 @@
#:use-module (gnu packages libevent)
#:use-module (gnu packages linux)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages password-utils)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -198,14 +199,14 @@ servers from Python programs.")
(define-public 389-ds-base
(package
(name "389-ds-base")
- (version "1.4.0.13")
+ (version "1.4.0.21")
(source (origin
(method url-fetch)
(uri (string-append "https://releases.pagure.org/389-ds-base/"
"389-ds-base-" version ".tar.bz2"))
(sha256
(base32
- "01dm3zq3w5ami9pwcjbjz8wfbx9krjxybjrgc4wyhrxlzd90ylzj"))))
+ "1qd1ap5d5nxyiq0d19czfwc3h7iwl9lmr5sy7d7xmpr2by59aysr"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((srfi srfi-1)
@@ -228,6 +229,11 @@ servers from Python programs.")
"--disable-perl")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-includes
+ (lambda _
+ (substitute* "include/ldaputil/certmap.h"
+ (("nss3/cert.h") "nss/cert.h"))
+ #t))
(add-after 'unpack 'fix-install-location-of-python-tools
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -286,6 +292,7 @@ servers from Python programs.")
#t)))))
(inputs
`(("bdb" ,bdb)
+ ("cracklib" ,cracklib)
("cyrus-sasl" ,cyrus-sasl)
("gnutls" ,gnutls)
("httpd" ,httpd)