summaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-10 02:34:08 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-12 20:49:13 +0100
commitaf0162bcc1057aeda9bcadd40dee5a884106f49f (patch)
tree37bd8504217777a1f18b3a0bd27877eb653b208b /gnu/packages/openldap.scm
parent56ba3771c0f35e2825559e536860e1659d683a64 (diff)
downloadguix-patches-af0162bcc1057aeda9bcadd40dee5a884106f49f.tar
guix-patches-af0162bcc1057aeda9bcadd40dee5a884106f49f.tar.gz
gnu: cyrus-sasl: Update to 2.1.27.
* gnu/packages/patches/cyrus-sasl-CVE-2013-4122.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/cyrus-sasl.scm (cyrus-sasl): Update to 2.1.27. [source](patches): Remove. [inputs]: Move MIT-KRB5 from here ... [propagated-inputs]: ... to here. New field. * gnu/packages/openldap.scm (openldap)[arguments]: Adjust 'patch-sasl-path' phase (which was defunct, possibly since b148506df74) to add krb5 linker flags.
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 850223cd4c..3cba8142bf 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -91,11 +91,15 @@
;; Give -L arguments for cyrus-sasl to avoid propagation.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
- (sasl (assoc-ref inputs "cyrus-sasl")))
+ (krb5 (assoc-ref inputs "mit-krb5"))) ;propagated from cyrus-sasl
+
+ ;; The ancient Libtool bundled with OpenLDAP copies the linker flags
+ ;; from Cyrus-SASL and embeds them into its own .la files. Add an
+ ;; absolute reference to Kerberos so it does not have to be propagated.
(substitute* (map (lambda (f) (string-append out "/" f))
'("lib/libldap.la" "lib/libldap_r.la"))
- (("-lsasl2" lib)
- (string-append "-L" sasl "/lib " lib)))
+ (("-lkrb5" lib)
+ (string-append "-L" krb5 "/lib " lib)))
#t))))))
(synopsis "Implementation of the Lightweight Directory Access Protocol")
(description