summaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-09 19:00:24 -0500
committerLeo Famulari <leo@famulari.name>2021-02-11 15:02:53 -0500
commita18492118cc73bee9a2e6424363e3e072572f52e (patch)
treec5e5e3890a7ab496b45746d0eeafebef04ef087c /gnu/packages/openldap.scm
parent7f891056d42ea334c1fdeefcdb608984d3f13879 (diff)
downloadguix-patches-a18492118cc73bee9a2e6424363e3e072572f52e.tar
guix-patches-a18492118cc73bee9a2e6424363e3e072572f52e.tar.gz
gnu: OpenLDAP: Update to 2.4.57 [security fixes].
Fixes CVE-2020-{36221,36222,36223,36224,36225,36226,36226,36228,36229,36230}. * gnu/packages/openldap.scm (openldap-2.4.57): New variable. (openldap)[replacement]: New field.
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm24
1 files changed, 23 insertions, 1 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index fb917882e7..c23a9f6c25 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -61,6 +61,7 @@
(define-public openldap
(package
(name "openldap")
+ (replacement openldap-2.4.57)
(version "2.4.50")
(source (origin
(method url-fetch)
@@ -125,6 +126,27 @@
(license openldap2.8)
(home-page "https://www.openldap.org/")))
+(define-public openldap-2.4.57
+ (package
+ (inherit openldap)
+ (version "2.4.57")
+ (source (origin
+ (method url-fetch)
+ ;; See <http://www.openldap.org/software/download/> for a list of
+ ;; mirrors.
+ (uri (list (string-append
+ "ftp://mirror.switch.ch/mirror/OpenLDAP/"
+ "openldap-release/openldap-" version ".tgz")
+ (string-append
+ "https://www.openldap.org/software/download/OpenLDAP/"
+ "openldap-release/openldap-" version ".tgz")
+ (string-append
+ "ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/"
+ "openldap-release/openldap-" version ".tgz")))
+ (sha256
+ (base32
+ "0nmlyqhc52v24b4awh914sczmvxbazgq2cnlycvb9dgcwvhlgfn7"))))))
+
(define-public nss-pam-ldapd
(package
(name "nss-pam-ldapd")