summaryrefslogtreecommitdiff
path: root/gnu/packages/openldap.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-06-03 16:43:07 -0400
committerLeo Famulari <leo@famulari.name>2017-06-04 14:57:59 -0400
commit4f493cba06b97de756123b3855ea52dcf1ad3555 (patch)
tree8af1fee4c9858b8887113b200eecae073206d0d4 /gnu/packages/openldap.scm
parentc9dba6c114580b0fabdb46bb9621c568c1958804 (diff)
downloadguix-patches-4f493cba06b97de756123b3855ea52dcf1ad3555.tar
guix-patches-4f493cba06b97de756123b3855ea52dcf1ad3555.tar.gz
gnu: openldap: Provide path to cyrus-sasl for libtool.
* gnu/packages/openldap.scm (openldap)[arguments]: Add 'patch-sasl-path' phase..
Diffstat (limited to 'gnu/packages/openldap.scm')
-rw-r--r--gnu/packages/openldap.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 8d27ac9666..f3963c6e20 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -73,7 +73,17 @@
(modify-phases %standard-phases
(add-after 'configure 'provide-libtool
(lambda _ (copy-file (which "libtool") "libtool")
- #t)))))
+ #t))
+ (add-after 'install 'patch-sasl-path
+ ;; Give -L arguments for cyrus-sasl to avoid propagation.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (sasl (assoc-ref inputs "cyrus-sasl")))
+ (substitute* (map (lambda (f) (string-append out "/" f))
+ '("lib/libldap.la" "lib/libldap_r.la"))
+ (("-lsasl2" lib)
+ (string-append "-L" sasl "/lib " lib)))
+ #t))))))
(synopsis "Implementation of the Lightweight Directory Access Protocol")
(description
"OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")