summaryrefslogtreecommitdiff
path: root/gnu/packages/openkinect.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/openkinect.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/openkinect.scm')
-rw-r--r--gnu/packages/openkinect.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/openkinect.scm b/gnu/packages/openkinect.scm
index 89e6c69cfc..e760f18367 100644
--- a/gnu/packages/openkinect.scm
+++ b/gnu/packages/openkinect.scm
@@ -64,9 +64,9 @@
(string-append rules-out "51-kinect.rules"))
#t))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("libusb" ,libusb)))
+ (list libusb))
(synopsis "Drivers and libraries for the Xbox Kinect device")
(description "libfreenect is a userspace driver for the Microsoft Kinect.
It supports: RGB and Depth Images, Motors, Accelerometer, LED and Audio.")
@@ -106,8 +106,7 @@ It supports: RGB and Depth Images, Motors, Accelerometer, LED and Audio.")
(inherit libfreenect)
(name "libfreenect-opencv")
(inputs
- `(("libfreenect" ,libfreenect)
- ("opencv" ,opencv)))
+ (list libfreenect opencv))
(arguments
`(#:tests? #f ; package has no tests
#:configure-flags '("-DBUILD_EXAMPLES=OFF"
@@ -124,12 +123,11 @@ library")))
(inherit libfreenect)
(name "python-libfreenect")
(native-inputs
- `(("python-cython" ,python-cython)))
+ (list python-cython))
(inputs
- `(("libfreenect" ,libfreenect)))
+ (list libfreenect))
(propagated-inputs
- `(("python" ,python)
- ("python-numpy" ,python-numpy)))
+ (list python python-numpy))
(arguments
`(#:tests? #f ; package has no tests
#:configure-flags '("-DBUILD_EXAMPLES=OFF"