summaryrefslogtreecommitdiff
path: root/gnu/packages/opencog.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-05 20:44:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-05 20:45:22 +0100
commit62af74b7148118f91a34eb1811935fda81a8e459 (patch)
tree619975e178678fd2322786ee9e67b562e14c7879 /gnu/packages/opencog.scm
parente088a010a257a439b6266209a3b0f9faba715ccf (diff)
downloadguix-patches-62af74b7148118f91a34eb1811935fda81a8e459.tar
guix-patches-62af74b7148118f91a34eb1811935fda81a8e459.tar.gz
gnu: Add agi-bio.
* gnu/packages/opencog.scm (agi-bio): New variable.
Diffstat (limited to 'gnu/packages/opencog.scm')
-rw-r--r--gnu/packages/opencog.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/opencog.scm b/gnu/packages/opencog.scm
index f9551a8e9f..a39b20542c 100644
--- a/gnu/packages/opencog.scm
+++ b/gnu/packages/opencog.scm
@@ -250,3 +250,46 @@ framework, and a number of cognitive agents at varying levels of completion,
some already displaying interesting and useful functionalities alone and in
combination.")
(license license:agpl3))))
+
+(define-public agi-bio
+ ;; There are no releases.
+ (let ((commit "b5c6f3d99e8cca3798bf0cdf2c32f4bdb8098efb")
+ (revision "1"))
+ (package
+ (name "agi-bio")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/opencog/agi-bio.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "083rqwlcnc99l4mxchj6r7x147nvfshmb39lkv15ik4cm9s3ldhw"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; there are none
+ #:configure-flags
+ (list
+ (string-append "-DGUILE_INCLUDE_DIR="
+ (assoc-ref %build-inputs "guile")
+ "/include/guile/2.2/")
+ (string-append "-DGUILE_SITE_DIR="
+ (assoc-ref %outputs "out")
+ "/share/guile/site/2.2/"))))
+ (inputs
+ `(("atomspace" ,atomspace)
+ ("cogutil" ,cogutil)
+ ("gmp" ,gmp)
+ ("guile" ,guile-2.2)))
+ (native-inputs
+ `(("cxxtest" ,cxxtest)
+ ("python" ,python-minimal)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/opencog/agi-bio")
+ (synopsis "Genomic and proteomic data exploration and pattern mining")
+ (description "This is a package for genomic and proteomic research using
+the OpenCog toolset with Guile. This includes experiments in applying pattern
+mining and other OpenCog components.")
+ (license license:agpl3))))