summaryrefslogtreecommitdiff
path: root/gnu/packages/openbox.scm
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-01-14 13:14:38 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-01-15 20:09:22 +0100
commit195469904465ece92c46bc9a76630dfdd7a982bb (patch)
treecff84fa530f57d302b4ba06fec887bf148b5f912 /gnu/packages/openbox.scm
parent49586905b8b82706d796f53d1e30fe334906843c (diff)
downloadguix-patches-195469904465ece92c46bc9a76630dfdd7a982bb.tar
guix-patches-195469904465ece92c46bc9a76630dfdd7a982bb.tar.gz
gnu: Add obconf.
* gnu/packages/openbox.scm (obconf): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/openbox.scm')
-rw-r--r--gnu/packages/openbox.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/openbox.scm b/gnu/packages/openbox.scm
index 36e39d8267..2200c837ba 100644
--- a/gnu/packages/openbox.scm
+++ b/gnu/packages/openbox.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,11 +24,13 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
@@ -67,4 +70,38 @@ implementations.")
(home-page "http://openbox.org/wiki/Main_Page")
(license gpl2+)))
+(define-public obconf
+ (package
+ (name "obconf")
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://openbox.org/dist/" name
+ "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fanjdmd8727kk74x5404vi8v7s4kpq48l583d12fsi4xvsfb8vi"))))
+ (inputs
+ `(("gtk+-2" ,gtk+-2)
+ ("imlib2" ,imlib2)
+ ("libglade" ,libglade)
+ ("openbox" ,openbox)
+ ("startup-notification" ,startup-notification)
+ ("libsm" ,libsm)
+ ("librsvg" ,librsvg)
+ ("libxft" ,libxft)))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags (list "--enable-nls")))
+ (home-page "http://openbox.org/wiki/ObConf:About")
+ (synopsis "Openbox configuration tool")
+ (description
+ "Obconf is a tool for configuring the Openbox window manager.
+You can configure its appearance, themes, and much more.")
+ (license gpl2+)))
+
;;; openbox.scm ends here