summaryrefslogtreecommitdiff
path: root/gnu/packages/onc-rpc.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-01-03 15:36:25 -0500
committerLeo Famulari <leo@famulari.name>2018-01-10 00:07:39 -0800
commite5227712213719d57a556418a675db0b838c040c (patch)
treeb82f3e03186a28162b6634a15f361b32ab112ca3 /gnu/packages/onc-rpc.scm
parent64a153bd1a81bd50f259553188edb2464221bb34 (diff)
downloadguix-patches-e5227712213719d57a556418a675db0b838c040c.tar
guix-patches-e5227712213719d57a556418a675db0b838c040c.tar.gz
gnu: libtirpc: Update to 1.0.2.
* gnu/packages/onc-rpc.scm (libtirpc): Update to 1.0.2. [source]: Adjust patch list. * gnu/packages/patches/libtirpc-CVE-2017-8779.patch: Delete file. * gnu/packages/patches/libtirpc-missing-headers.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/onc-rpc.scm')
-rw-r--r--gnu/packages/onc-rpc.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/onc-rpc.scm b/gnu/packages/onc-rpc.scm
index a76ac36eab..bd1b6f0584 100644
--- a/gnu/packages/onc-rpc.scm
+++ b/gnu/packages/onc-rpc.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
-;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30,16 +30,16 @@
(define-public libtirpc
(package
(name "libtirpc")
- (version "1.0.1")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
version "/libtirpc-"
version ".tar.bz2"))
- (patches (search-patches "libtirpc-CVE-2017-8779.patch"))
+ (patches (search-patches "libtirpc-missing-headers.patch"))
(sha256
(base32
- "17mqrdgsgp9m92pmq7bvr119svdg753prqqxmg4cnz5y657rfmji"))))
+ "1xchbxy0xql7yl7z4n1icj8r7dmly46i22fvm00vdjq64zlmqg3j"))))
(build-system gnu-build-system)
(arguments
`(#:phases