summaryrefslogtreecommitdiff
path: root/gnu/packages/ocr.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2019-08-06 23:43:55 +0800
committerAlex Vong <alexvong1995@gmail.com>2019-09-17 13:28:52 +0800
commit9a94ccec4c14dab78326b2b1c449cd4ccd987bcb (patch)
tree62f1baad39f55312967d19bfc5a0e0958dc2bfee /gnu/packages/ocr.scm
parent82c4ad9646aa65f96a809d089f318680126d8b39 (diff)
downloadguix-patches-9a94ccec4c14dab78326b2b1c449cd4ccd987bcb.tar
guix-patches-9a94ccec4c14dab78326b2b1c449cd4ccd987bcb.tar.gz
gnu: Add zinnia.
* gnu/packages/ocr.scm (zinnia): New variable.
Diffstat (limited to 'gnu/packages/ocr.scm')
-rw-r--r--gnu/packages/ocr.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 2808359ca2..14ea7e443b 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,6 +23,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages compression)
#:use-module (gnu packages image))
@@ -76,3 +78,56 @@ positional information and page layout analysis. Several image formats are
supported through the Leptonica library. It can also detect whether text is
monospaced or proportional.")
(license license:asl2.0)))
+
+(define-public zinnia
+ (let* ((commit "581faa8f6f15e4a7b21964be3a5ec36265c80e5b")
+ (revision "1")
+ ;; version copied from 'configure.in'
+ (version (git-version "0.07" revision commit)))
+ (package
+ (name "zinnia")
+ (version version)
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taku910/zinnia.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "1izjy5qw6swg0rs2ym2i72zndb90mwrfbd1iv8xbpwckbm4899lg"))
+ (file-name (git-file-name name version))
+ (modules '((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-26)))
+ (snippet ; remove unnecessary files with potentially different license
+ '(begin
+ (for-each delete-file-recursively
+ (scandir "."
+ (negate (cut member <> '("zinnia"
+ "." "..")))))
+ #t))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (chdir "zinnia")
+ (for-each make-file-writable
+ '("config.log" "config.status"))
+ #t)))))
+ (home-page "https://taku910.github.io/zinnia/")
+ (synopsis "Online hand recognition system with machine learning")
+ (description
+ "Zinnia is a simple, customizable and portable online hand recognition
+system based on Support Vector Machines. Zinnia simply receives user pen
+strokes as a sequence of coordinate data and outputs n-best characters sorted
+by SVM confidence. To keep portability, Zinnia doesn't have any rendering
+functionality. In addition to recognition, Zinnia provides training module
+that allows us to create any hand-written recognition systems with low-cost.")
+ (license (list license:bsd-3 ; all files except...
+ (license:non-copyleft ; some autotools related files
+ "file://zinnia/aclocal.m4")
+ license:x11 ; 'install-sh'
+ license:public-domain))))) ; 'install-sh'