summaryrefslogtreecommitdiff
path: root/gnu/packages/ocr.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-07-21 17:18:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-07-21 17:18:42 +0300
commit427dda54f263acd5b8898a981027ba5351933ba8 (patch)
treed92bb386d112175eeaaef8f6c9ba5510148f0fac /gnu/packages/ocr.scm
parenta9c64810cdf1cd0de66e327162348d0b2d477452 (diff)
downloadguix-patches-427dda54f263acd5b8898a981027ba5351933ba8.tar
guix-patches-427dda54f263acd5b8898a981027ba5351933ba8.tar.gz
gnu: tesseract-ocr: Update to 3.04.01.
* gnu/packages/ocr.scm (tesseract-ocr): Update to 3.04.01. [source]: Download from Github, add 'file-name' field, remove snippet. [native-inputs]: Remove autoconf, automake, libtool. [propagated-inputs]: Move leptonica ... [inputs]: ... to here. [arguments]: Remove 'autogen phase. [home-page]: Move program's home-page to Github.
Diffstat (limited to 'gnu/packages/ocr.scm')
-rw-r--r--gnu/packages/ocr.scm34
1 files changed, 9 insertions, 25 deletions
diff --git a/gnu/packages/ocr.scm b/gnu/packages/ocr.scm
index 0d5fbcdc29..2e205ddd34 100644
--- a/gnu/packages/ocr.scm
+++ b/gnu/packages/ocr.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,10 +22,8 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
- #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
- #:use-module (gnu packages image)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages image))
(define-public ocrad
(package
@@ -50,39 +49,24 @@ it produces text in 8-bit or UTF-8 formats.")
(define-public tesseract-ocr
(package
(name "tesseract-ocr")
- (version "3.02.02")
+ (version "3.04.01")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://tesseract-ocr.googlecode.com/files/tesseract-ocr-"
+ "https://github.com/tesseract-ocr/tesseract/archive/"
version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0g81m9y4iydp7kgr56mlkvjdwpp3mb01q385yhdnyvra7z5kkk96"))
- (modules '((guix build utils)))
- ;; Leptonica added a pkg-config file in the meanwhile.
- (snippet
- '(substitute* "tesseract.pc.in"
- (("^# Requires: lept ## .*")
- "Requires: lept\n")))))
+ (base32 "0snwd8as5i8vx7zkimpd2yg898jl96zf90r65a9w615f2hdkxxjp"))))
(build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)))
- (propagated-inputs
+ (inputs
`(("leptonica" ,leptonica)))
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after
- 'unpack 'autogen
- (lambda _
- (zero? (system* "sh" "autogen.sh")))))
- #:configure-flags
+ '(#:configure-flags
(let ((leptonica (assoc-ref %build-inputs "leptonica")))
(list (string-append "LIBLEPT_HEADERSDIR=" leptonica "/include")))))
- (home-page "https://code.google.com/p/tesseract-ocr/")
+ (home-page "https://github.com/tesseract-ocr")
(synopsis "Optical character recognition engine")
(description
"Tesseract is an optical character recognition (OCR) engine with very