summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-19 17:50:38 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-20 02:13:48 +0200
commitfe6fd923a8b5a8307ae47c1f218dc9b9b41a722d (patch)
treee61a257e0d589141673345fc4bd4f495a0060cd2 /gnu/packages/ocaml.scm
parent96dce8c7fe0d86a7997a771e60b735789f97bc19 (diff)
downloadguix-patches-fe6fd923a8b5a8307ae47c1f218dc9b9b41a722d.tar
guix-patches-fe6fd923a8b5a8307ae47c1f218dc9b9b41a722d.tar.gz
gnu: Add ocaml-mparser.
* gnu/packages/ocaml.scm (ocaml-mparser): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 22767ee2a2..0117f6dca2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6799,6 +6799,34 @@ in the documentation always stays up-to-date.
compatibility.")
(license license:isc)))
+(define-public ocaml-mparser
+ (package
+ (name "ocaml-mparser")
+ (version "1.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/murmour/mparser")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16j19v16r42gcsii6a337zrs5cxnf12ig0vaysxyr7sq5lplqhkx"))))
+ (build-system dune-build-system)
+ (arguments
+ ;; No tests.
+ '(#:package "mparser"
+ #:tests? #f))
+ (home-page "https://github.com/murmour/mparser")
+ (synopsis "Simple monadic parser combinator library")
+ (description
+ "This library implements a rather complete and efficient monadic parser
+combinator library similar to the Parsec library for Haskell by Daan Leijen and
+the FParsec library for FSharp by Stephan Tolksdorf.")
+ ;; With static linking exception.
+ (license license:lgpl2.1+)))
+
(define-public lablgtk3
(package
(name "lablgtk")