summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:22:46 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-03-14 22:09:33 +0100
commitef0051b2c5a5d97d3a699a960e8d2d774879d07d (patch)
tree97c8b68f53807796dfc1a1d0c963d163b39333f6 /gnu/packages/ocaml.scm
parentd19c1b410508eee5824582d0ac6d8b00de483bbb (diff)
downloadguix-patches-ef0051b2c5a5d97d3a699a960e8d2d774879d07d.tar
guix-patches-ef0051b2c5a5d97d3a699a960e8d2d774879d07d.tar.gz
gnu: Add ocaml-typerep.
* gnu/packages/ocaml.scm (ocaml-typerep): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dc2ce14d30..ce6c7fb8c4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2297,3 +2297,19 @@ by making sure that you only compare comparable values.")
(description "Sexplib contains functionality for parsing and pretty-printing
s-expressions.")
(license license:asl2.0)))
+
+(define-public ocaml-typerep
+ (package
+ (name "ocaml-typerep")
+ (version "113.33.03")
+ (source (janestreet-origin "typerep" version
+ "1b9v5bmi824a9d4sx0f40ixq0yfcbiqxafg4a1jx95xg9199zafy"))
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/typerep/")
+ (synopsis "Typerep is a library for runtime types")
+ (description "Typerep is a library for runtime types.")
+ (license license:asl2.0)))