summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-22 18:36:57 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-24 02:13:44 +0100
commitddea3012367961204726c0f08fd6c95111f58c4d (patch)
tree69f1c328d3001c2a61d0192c5e54f58ca08ef720 /gnu/packages/ocaml.scm
parentb2a725c6792bfc278ee200f461a1765c28bd444b (diff)
downloadguix-patches-ddea3012367961204726c0f08fd6c95111f58c4d.tar
guix-patches-ddea3012367961204726c0f08fd6c95111f58c4d.tar.gz
gnu: Add ocaml-mew.
* gnu/packages/ocaml.scm (ocaml-mew): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5e195572ec..427ee2c682 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7457,6 +7457,32 @@ these missing pieces.")
OCaml.")
(license license:expat)))
+(define-public ocaml-mew
+ (package
+ (name "ocaml-mew")
+ (version "0.1.0")
+ (home-page "https://github.com/kandu/mew")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0417xsghj92v3xa5q4dk4nzf2r4mylrx2fd18i7cg3nzja65nia2"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("ocaml-result" ,ocaml-result)
+ ("ocaml-trie" ,ocaml-trie)))
+ (native-inputs
+ `(("ocaml-ppx-expect" ,ocaml-ppx-expect)))
+ (synopsis "General modal editing engine generator")
+ (description
+ "This package provides the core modules of Modal Editing Witch, a general
+modal editing engine generator.")
+ (license license:expat)))
+
(define-public ocaml-syntax-shims
(package
(name "ocaml-syntax-shims")