summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-10-01 14:33:00 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-10-15 18:01:15 +0200
commitc49b94a56c5c42c04e5c73c4be2533badeae19d4 (patch)
tree62e57a09391fff297cd695345189e2e2f86d8b34 /gnu/packages/ocaml.scm
parent171abdd8f5194af0a141c2f5e2d542c3c89a00b0 (diff)
downloadguix-patches-c49b94a56c5c42c04e5c73c4be2533badeae19d4.tar
guix-patches-c49b94a56c5c42c04e5c73c4be2533badeae19d4.tar.gz
gnu: ocaml-compiler-libs: Build only with OCaml 4.07.
* gnu/packages/ocaml.scm (ocaml-compiler-libs): Rename to... (ocaml4.07-compiler-libs): ...to this. Use OCaml 4.07.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e01b0346b0..7c7963970b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3574,7 +3574,7 @@ syntax checking on dedukti files.")
`(("ocaml-base" ,ocaml4.07-base)
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-compiler-libs" ,(package-with-ocaml4.07 ocaml-compiler-libs))
+ ("ocaml-compiler-libs" ,ocaml4.07-compiler-libs)
("ocaml-sexplib0" ,ocaml4.07-sexplib0)
("ocaml-stdio" ,ocaml4.07-stdio)
("ocaml-ppxlib" ,ocaml4.07-ppxlib)))
@@ -4092,9 +4092,9 @@ provided by companion libraries such as
@url{https://github.com/janestreet/stdio, ocaml-stdio}.")
(license license:expat)))
-(define-public ocaml-compiler-libs
+(define-public ocaml4.07-compiler-libs
(package
- (name "ocaml-compiler-libs")
+ (name "ocaml4.07-compiler-libs")
(version "0.11.0")
(home-page "https://github.com/janestreet/ocaml-compiler-libs")
(source
@@ -4109,7 +4109,10 @@ provided by companion libraries such as
"03jds7bszh8wwpfwxb3dg0gyr1j1872wxwx1xqhry5ir0i84bg0s"))))
(build-system dune-build-system)
(arguments
- '(#:tests? #f)) ;no tests
+ `(#:tests? #f ;no tests
+ #:ocaml ,ocaml-4.07
+ #:findlib ,ocaml4.07-findlib
+ #:dune ,ocaml4.07-dune))
(properties `((upstream-name . "ocaml-compiler-libs")))
(synopsis "Compiler libraries repackaged")
(description "This package simply repackages the OCaml compiler libraries
@@ -4192,7 +4195,7 @@ as part of the same ocaml-migrate-parsetree driver.")
(build-system dune-build-system)
(propagated-inputs
`(("ocaml-base" ,ocaml4.07-base)
- ("ocaml-compiler-libs" ,(package-with-ocaml4.07 ocaml-compiler-libs))
+ ("ocaml-compiler-libs" ,ocaml4.07-compiler-libs)
("ocaml-migrate-parsetree"
,(package-with-ocaml4.07 ocaml-migrate-parsetree))
("ocaml-ppx-derivers" ,(package-with-ocaml4.07 ocaml-ppx-derivers))