summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:38:35 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:11:54 +0100
commitc0505c907302bfd72afe885fa5484fd845055c09 (patch)
tree337a9ae47602b91e7facc63602f4ae12fd6a2b2b /gnu/packages/ocaml.scm
parentdee924ac2635352cd744c4d04c25a0c16736675c (diff)
downloadguix-patches-c0505c907302bfd72afe885fa5484fd845055c09.tar
guix-patches-c0505c907302bfd72afe885fa5484fd845055c09.tar.gz
gnu: Remove ocaml4.07-ppx-compare.
* gnu/packages/ocaml.scm (ocaml4.07-ppx-compare): Remove variable. (ocaml-ppx-compare)[properties]: Remove variant. Change-Id: Idac9eb2fe20e6849a791b758507211b47969aafa
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 902417fb9b..d36edf73e8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6433,8 +6433,7 @@ OCaml AST in the OCaml syntax;
'(#:tests? #f))
(propagated-inputs
(list ocaml-base ocaml-migrate-parsetree ocaml-ppxlib))
- (properties `((upstream-name . "ppx_compare")
- (ocaml4.07-variant . ,(delay ocaml4.07-ppx-compare))))
+ (properties `((upstream-name . "ppx_compare")))
(home-page "https://github.com/janestreet/ppx_compare")
(synopsis "Generation of comparison functions from types")
(description "Generation of fast comparison functions from type expressions
@@ -6445,24 +6444,6 @@ flexibility by allowing you to override them for a specific type and more safety
by making sure that you only compare comparable values.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-compare
- (package-with-ocaml4.07
- (package
- (inherit ocaml-ppx-compare)
- (name "ocaml-ppx-compare")
- (version "0.11.1")
- (home-page "https://github.com/janestreet/ppx_compare")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06bq4m1bsm4jlx4g7wh5m99qky7xm4c2g52kaz6pv25hdn5agi2m"))))
- (properties `((upstream-name . "ppx_compare"))))))
-
(define-public ocaml-fieldslib
(package
(name "ocaml-fieldslib")