summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-09-30 23:38:35 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-10-15 18:00:28 +0200
commitbd2ad4a1950b4cddfc63306143e7edb28b283c36 (patch)
tree7c056ad76e90f2d068f94146a863c756c89431eb /gnu/packages/ocaml.scm
parentef841e96b97c7ee9517219e6eb2f779cc4686a0d (diff)
downloadguix-patches-bd2ad4a1950b4cddfc63306143e7edb28b283c36.tar
guix-patches-bd2ad4a1950b4cddfc63306143e7edb28b283c36.tar.gz
gnu: ocaml-base64: Update to 3.4.0.
* gnu/packages/ocaml.scm (ocaml-base64): Update to 3.4.0.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 756960d587..81e923df63 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2233,7 +2233,7 @@ multitude of other network protocols (FTP/SMTP/RTSP/etc).")
(define-public ocaml-base64
(package
(name "ocaml-base64")
- (version "3.2.0")
+ (version "3.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2242,8 +2242,19 @@ multitude of other network protocols (FTP/SMTP/RTSP/etc).")
(file-name (git-file-name name version))
(sha256
(base32
- "1ilw3zj0w6cq7i4pvr8m2kv5l5f2y9aldmv72drlwwns013b1gwy"))))
+ "0aa1m1sr8p1hgc10p96mij7p22r3qcysvzy6fz2jqamfgswchgqc"))))
(build-system dune-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-dune
+ (lambda _
+ ;; This package expects dune 2, which unbundled its configurator
+ ;; module. We still use dune 1, so we need to let it know we need
+ ;; its internal module.
+ (substitute* "config/dune"
+ (("dune-configurator") "dune.configurator"))
+ #t)))))
(native-inputs
`(("ocaml-alcotest" ,ocaml-alcotest)
("ocaml-bos" ,ocaml-bos)