summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-03 23:12:43 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-03 23:32:30 +0200
commita21ea76fbf8cc82653f038ded323fe88d1d785e7 (patch)
treec8e78dddf0330cdf52876f3d736fb58ecf61482a /gnu/packages/ocaml.scm
parente60330510a0c0b6c080a0878be6aa40644456314 (diff)
downloadguix-patches-a21ea76fbf8cc82653f038ded323fe88d1d785e7.tar
guix-patches-a21ea76fbf8cc82653f038ded323fe88d1d785e7.tar.gz
gnu: Add ocaml-stdlib-shims.
* gnu/packages/ocaml.scm (ocaml-stdlib-shims): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3f661b74e1..d66910cb4a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2383,6 +2383,28 @@ language.")
can match the question using a regular expression or a timeout.")
(license license:lgpl2.1+))) ; with the OCaml static compilation exception
+(define-public ocaml-stdlib-shims
+ (package
+ (name "ocaml-stdlib-shims")
+ (version "0.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/stdlib-shims")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "007dwywsr5285z0np6a9nr0h8iqmyzfrlx6s5xaqcwj69zabsrjm"))))
+ (build-system dune-build-system)
+ (home-page "https://github.com/ocaml/stdlib-shims")
+ (synopsis "OCaml stdlib features backport to older OCaml compilers")
+ (description "This package backports some of the new stdlib features to
+older compilers, such as the Stdlib module. This allows projects that require
+compatibility with older compiler to use these new features in their code.")
+ ;; with ocaml-linking exception
+ (license license:lgpl2.1+)))
+
(define-public ocaml-fileutils
(package
(name "ocaml-fileutils")