summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:17:09 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:13:19 +0100
commit9dc7dcb26129c182ba564d886ea43a651fd176a2 (patch)
treef0192c4137de9571fcb6f053345518fc2da7796b /gnu/packages/ocaml.scm
parent66da3a9f319293f42906117388814b98ddb71b79 (diff)
downloadguix-patches-9dc7dcb26129c182ba564d886ea43a651fd176a2.tar
guix-patches-9dc7dcb26129c182ba564d886ea43a651fd176a2.tar.gz
gnu: Add ocaml-logs.
* gnu/packages/ocaml.scm (ocaml-logs): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9a70c47536..c17aaf8e3f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1443,3 +1443,34 @@ make it easy to run normally-blocking I/O operations concurrently in a single
process. Also, in many cases, Lwt threads can interact without the need for
locks or other synchronization primitives.")
(license license:lgpl2.1)))
+
+(define-public ocaml-logs
+ (package
+ (name "ocaml-logs")
+ (version "0.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/logs/releases/"
+ "logs-" version ".tbz"))
+ (sha256
+ (base32
+ "1khbn7jqpid83zn8rvyh1x1sirls7zc878zj4fz985m5xlsfy853"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:tests? #f
+ #:build-flags (list "build" "--with-js_of_ocaml" "false")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs `(("opam" ,opam)))
+ (propagated-inputs `(("fmt" ,ocaml-fmt)
+ ("lwt" ,ocaml-lwt)
+ ("mtime" ,ocaml-mtime)
+ ("result" ,ocaml-result)
+ ("cmdliner" ,ocaml-cmdliner)
+ ("topkg" ,ocaml-topkg)))
+ (home-page "http://erratique.ch/software/logs")
+ (synopsis "Logging infrastructure for OCaml")
+ (description "Logs provides a logging infrastructure for OCaml. Logging is
+performed on sources whose reporting level can be set independently. Log
+message report is decoupled from logging and is handled by a reporter.")
+ (license license:isc)))