summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-12-28 22:10:15 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-12-30 14:26:29 +0100
commit995685738e0aecfcf6d645334a3d64ac427854af (patch)
tree474f5c05c3ac90b3a78097f1f8fd92de0c103a2d /gnu/packages/ocaml.scm
parentf6979a7d9f0cf903113e3beaa606c003084e85c7 (diff)
downloadguix-patches-995685738e0aecfcf6d645334a3d64ac427854af.tar
guix-patches-995685738e0aecfcf6d645334a3d64ac427854af.tar.gz
gnu: Add ocaml-dot-merlin-reader.
* gnu/packages/ocaml.scm (ocaml-dot-merlin-reader): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c5b845c049..758caa5bc4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3909,6 +3909,33 @@ Mercurial's @code{https://www.selenic.com/blog/?p=663, unified test
format}. @code{craml} is released as a single binary (called @code{craml}).")
(license license:isc)))
+(define-public ocaml-dot-merlin-reader
+ (package
+ (name "ocaml-dot-merlin-reader")
+ (version "3.4.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/merlin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0i2nwkdh6cfzmnsdsr8aw86vs8j1k5jkjzrs61b9384wnffdbbmj"))))
+ (build-system dune-build-system)
+ (arguments '(#:package "dot-merlin-reader"
+ #:tests? #f)) ; no tests
+ (inputs
+ `(("ocaml-yojson" ,ocaml-yojson)
+ ("ocaml-csexp" ,ocaml-csexp)
+ ("ocaml-result" ,ocaml-result)))
+ (home-page "https://ocaml.github.io/merlin/")
+ (synopsis "Reads config files for @code{ocaml-merlin}")
+ (description "@code{ocaml-dot-merlin-reader} is an external reader for
+@code{ocaml-merlin} configurations.")
+ (license license:expat)))
+
(define-public ocaml4.07-merlin
(package
(name "ocaml4.07-merlin")