summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-06-19 12:52:17 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-06-19 12:54:27 +0200
commit9417fae9fb21772a86f0d279f019b0caf2d71e77 (patch)
treedd969e1d1fe7ed4901bd44a2f373a0b77ec51677 /gnu/packages/ocaml.scm
parentc85ed0e758d7fa230c08dba6b95c65ceac098d50 (diff)
downloadguix-patches-9417fae9fb21772a86f0d279f019b0caf2d71e77.tar
guix-patches-9417fae9fb21772a86f0d279f019b0caf2d71e77.tar.gz
gnu: cubicle: Fix build with newer ocaml-num.
* gnu/packages/ocaml.scm (cubicle)[arguments]: Adjust Makefile for changes in ocaml-num.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a47267916c..3c781d51e4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4728,10 +4728,13 @@ the OCaml language.")
(add-before 'configure 'fix-ocaml-num
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "Makefile.in"
+ (("nums.cma") "num.cma num_core.cma")
(("= \\$\\(FUNCTORYLIB\\)")
(string-append "= -I "
(assoc-ref inputs "ocaml-num")
- "/lib/ocaml/site-lib"
+ "/lib/ocaml/site-lib/num/core -I "
+ (assoc-ref inputs "ocaml-num")
+ "/lib/ocaml/site-lib/num"
" $(FUNCTORYLIB)")))
#t)))))
(home-page "http://cubicle.lri.fr/")