summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorgabrielhdt <gabrielhondet@gmail.com>2019-05-04 14:48:38 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-05-14 21:37:57 +0200
commit908a2ee0ed47b3982eaf51577509e17877c96fdc (patch)
tree6024566d0015fed86cae458beaa8070a88249457 /gnu/packages/ocaml.scm
parente2506afcaf916ff71d4b79d8257b573de4243c3b (diff)
downloadguix-patches-908a2ee0ed47b3982eaf51577509e17877c96fdc.tar
guix-patches-908a2ee0ed47b3982eaf51577509e17877c96fdc.tar.gz
gnu: Add ocaml-bisect-ppx.
* gnu/packages/ocaml.scm (ocaml-bisect-ppx): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ee38b093f2..52f75f5c48 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5043,3 +5043,33 @@ directly by this package, or DOM trees (@code{js_of_ocaml-tyxml}) virtual DOM
also create your own representation and use it to instantiate a new set of
combinators.")
(license license:lgpl2.1)))
+
+(define-public ocaml-bisect-ppx
+ (package
+ (name "ocaml-bisect-ppx")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aantron/bisect_ppx.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vp3qvrkz7q25nbmvd40vhsnz2k9aqh17bnd21i3q8q0xlr5hdag"))))
+ (build-system dune-build-system)
+ (inputs
+ `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
+ ("ocaml-ounit" ,ocaml-ounit)))
+ (home-page "https://github.com/aantron/bisect_ppx")
+ (synopsis "Code coverage for OCaml")
+ (description "Bisect_ppx helps you test thoroughly. It is a small
+preprocessor that inserts instrumentation at places in your code, such as
+if-then-else and match expressions. After you run tests, Bisect_ppx gives a
+nice HTML report showing which places were visited and which were missed.
+
+Usage is simple - add package bisect_ppx when building tests, run your tests,
+then run the Bisect_ppx report tool on the generated visitation files.")
+ (license license:mpl2.0)))