summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-05-15 14:44:28 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-05-15 14:44:58 +0200
commit89651117686da547ac6b1a97dbfeee601dd06934 (patch)
tree5615e95f64a3f600ad8291fdbe1aa45f53392528 /gnu/packages/ocaml.scm
parent68f3ba37db8e60b3c43dbd8060275b6a8293ba78 (diff)
downloadguix-patches-89651117686da547ac6b1a97dbfeee601dd06934.tar
guix-patches-89651117686da547ac6b1a97dbfeee601dd06934.tar.gz
gnu: ocaml-octavius: Update to 1.2.2.
* gnu/packages/ocaml.scm (ocaml-octavius): Update to 1.2.2.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 525854676f..39d56e9fe0 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4429,7 +4429,7 @@ storage of large amounts of data.")
(define-public ocaml-octavius
(package
(name "ocaml-octavius")
- (version "1.2.1")
+ (version "1.2.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4438,8 +4438,17 @@ storage of large amounts of data.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ck6yj6z5rvqyl39rz87ca1bnk0f1dpgvlk115631hjh8bwpfvfq"))))
+ "1c5m51xcn2jv42kjjpklr6g63sgx1k885wfdp1yr4wrmiaj9cbpx"))))
(build-system dune-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'make-writable
+ (lambda _
+ (for-each (lambda (file)
+ (chmod file #o644))
+ (find-files "." "."))
+ #t)))))
(properties `((upstream-name . "octavius")))
(home-page "https://github.com/ocaml-doc/octavius")
(synopsis "Ocamldoc comment syntax parser")