summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-22 18:37:02 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-24 02:13:55 +0100
commit8365b4a0a3ff110069840191df80a6cb9795f727 (patch)
tree8960346857287b8317c8f5593aa29eeac7c2537c /gnu/packages/ocaml.scm
parent1221eb5f45f1dac2a41977cdbb47e1968dbd4455 (diff)
downloadguix-patches-8365b4a0a3ff110069840191df80a6cb9795f727.tar
guix-patches-8365b4a0a3ff110069840191df80a6cb9795f727.tar.gz
gnu: Add ocaml-utop.
* gnu/packages/ocaml.scm (ocaml-utop): New variable. (ocaml4.07-utop): Inherit and adjust. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm48
1 files changed, 34 insertions, 14 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 52ef4f3b65..82a675dc3d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4125,10 +4125,10 @@ instead of bindings to a C library.")
("ocaml-zed" ,ocaml-zed)))
(properties '()))))
-(define-public ocaml4.07-utop
+(define-public ocaml-utop
(package
- (name "ocaml4.07-utop")
- (version "2.4.3")
+ (name "ocaml-utop")
+ (version "2.8.0")
(source
(origin
(method git-fetch)
@@ -4137,21 +4137,19 @@ instead of bindings to a C library.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1bl4943qpi3qy152dbdm5glhx19zsiylmn4rcxi8l66g58hikyjp"))))
+ (base32 "1zf4hg33sblzh2f65vk0292jg4jlwa8702kfwpsg1kcg4w6nsfdp"))))
(build-system dune-build-system)
(arguments
- `(#:test-target "."
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
+ `(#:test-target "."))
(native-inputs
- `(("cppo" ,(package-with-ocaml4.07 ocaml-cppo))))
+ `(("ocaml-cppo" ,ocaml-cppo)))
(propagated-inputs
- `(("lambda-term" ,ocaml4.07-lambda-term)
- ("lwt" ,(package-with-ocaml4.07 ocaml-lwt))
- ("react" ,(package-with-ocaml4.07 ocaml-react))
- ("camomile" ,(package-with-ocaml4.07 ocaml-camomile))
- ("zed" ,ocaml4.07-zed)))
+ `(("ocaml-lambda-term" ,ocaml-lambda-term)
+ ("ocaml-lwt" ,ocaml-lwt)
+ ("ocaml-lwt-react" ,ocaml-lwt-react)
+ ("ocaml-camomile" ,ocaml-camomile)
+ ("ocaml-react" ,ocaml-react)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-utop))))
(home-page "https://github.com/ocaml-community/utop")
(synopsis "Improved interface to the OCaml toplevel")
(description "UTop is an improved toplevel for OCaml. It can run in a
@@ -4159,6 +4157,28 @@ terminal or in Emacs. It supports line editing, history, real-time and context
sensitive completion, colors, and more.")
(license license:bsd-3)))
+(define-public ocaml4.07-utop
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-utop)
+ (version "2.4.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml-community/utop")
+ (commit version)))
+ (file-name (git-file-name "ocaml4.07-utop" version))
+ (sha256
+ (base32 "1bl4943qpi3qy152dbdm5glhx19zsiylmn4rcxi8l66g58hikyjp"))))
+ (propagated-inputs
+ `(("ocaml-lambda-term" ,ocaml-lambda-term)
+ ("ocaml-lwt" ,ocaml-lwt)
+ ("ocaml-react" ,ocaml-react)
+ ("ocaml-camomile" ,ocaml-camomile)
+ ("ocaml-zed" ,ocaml-zed)))
+ (properties '()))))
+
(define-public ocaml-integers
(package
(name "ocaml-integers")