summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:23:16 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-13 17:15:37 +0200
commit7c8fcd284b0e106500b701f6ad4259ff8ff261fb (patch)
tree24676700bb0d6f0087708783a56ef1148de0e48d /gnu/packages/ocaml.scm
parent847960d38a495da173ddd442394fe0186ba7d1c5 (diff)
downloadguix-patches-7c8fcd284b0e106500b701f6ad4259ff8ff261fb.tar
guix-patches-7c8fcd284b0e106500b701f6ad4259ff8ff261fb.tar.gz
gnu: Add ocaml-time-now.
* gnu/packages/ocaml.scm (ocaml-time-now): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9471e8fa16..92afdbf80a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4180,6 +4180,31 @@ recommend using this package directly.")
packages.")
(license license:expat)))
+(define-public ocaml-time-now
+ (package
+ (name "ocaml-time-now")
+ (version "0.14.0")
+ (source
+ (janestreet-origin
+ "time_now" version
+ "0hkn2jw4dz5gflnsblskl5wp6z7zbrahwjmaxmsskfviwjg82cqh"))
+ (build-system dune-build-system)
+ (arguments '(#:tests? #f)) ; no tests
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-jane-street-headers" ,ocaml-jane-street-headers)
+ ("ocaml-jst-config" ,ocaml-jst-config)
+ ("ocaml-ppx-base" ,ocaml-ppx-base)
+ ("ocaml-ppx-optcomp" ,ocaml-ppx-optcomp)))
+ (properties `((upstream-name . "time_now")))
+ (home-page
+ "https://github.com/janestreet/time_now")
+ (synopsis "Reports the current time")
+ (description
+ "Provides a single function to report the current time in nanoseconds
+since the start of the Unix epoch.")
+ (license license:expat)))
+
(define-public ocaml4.07-ppx-inline-test
(package
(name "ocaml4.07-ppx-inline-test")