summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-12-28 22:10:03 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-12-30 14:25:39 +0100
commit77ca156ab2b3a89b2e15d9de4912ad8e022c2c78 (patch)
tree61a8031fdae089f4b691504cdafb87510a35cb6e /gnu/packages/ocaml.scm
parentd1d092f198c7a934beab71eaf91a442a8561f767 (diff)
downloadguix-patches-77ca156ab2b3a89b2e15d9de4912ad8e022c2c78.tar
guix-patches-77ca156ab2b3a89b2e15d9de4912ad8e022c2c78.tar.gz
gnu: Remove ocaml-js-build-tools.
The package is deprecated and no longer maintained. It is recommended to use dune instead. * gnu/packages/ocaml.xyz (ocaml-js-build-tools, janestreet-origin) (janestreet-arguments): Remove variables. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm65
1 files changed, 1 insertions, 64 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c4900b6214..64c8633af3 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 divoplade <d@divoplade.fr>
+;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -93,47 +94,6 @@
(number->string file-number) "/" name "-" version
".tar.gz"))
-;; Janestreet packages are found in a similar way and all need the same patch.
-(define (janestreet-origin name version hash)
- (origin (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/"
- (version-major+minor version) "/files/"
- name "-" version ".tar.gz"))
- (sha256 (base32 hash))
- (modules '((guix build utils)))
- (snippet
- (let ((pattern (string-append "lib/" name)))
- `(begin
- ;; install.ml contains an invalid reference to the ppx file and
- ;; propagates this error to the generated META file. It
- ;; looks for it in the "lib" directory, but it is installed in
- ;; "lib/ocaml/site-lib/package". This substitute does not change
- ;; this file for non ppx packages.
- (substitute* "install.ml"
- ((,pattern) (string-append "lib/ocaml/site-lib/" ,name)))
- ;; The standard Makefile would try to install janestreet modules
- ;; in OCaml's directory in the store, which is read-only.
- (substitute* "Makefile"
- (("--prefix")
- "--libdir $(LIBDIR) --prefix"))
- #t)))))
-
-;; They also require almost the same set of arguments
-(define janestreet-arguments
- `(#:use-make? #t
- #:make-flags
- (list (string-append "CONFIGUREFLAGS=--prefix "
- (assoc-ref %outputs "out")
- " --enable-tests")
- (string-append "LIBDIR="
- (assoc-ref %outputs "out")
- "/lib/ocaml/site-lib")
- ;; for ocaml-bin-prot, otherwise ignored
- (string-append "OCAML_TOPLEVEL_PATH="
- (assoc-ref %build-inputs "findlib")
- "/lib/ocaml/site-lib"))
- #:phases (modify-phases %standard-phases (delete 'configure))))
-
(define-public ocaml-4.11
(package
(name "ocaml")
@@ -2716,29 +2676,6 @@ system in your OCaml projects. It helps to create standard entry points in your
build system and allows external tools to analyse your project easily.")
(license license:lgpl2.1+))) ; with ocaml static compilation exception
-(define-public ocaml-js-build-tools
- (package
- (name "ocaml-js-build-tools")
- (version "113.33.06")
- (source (janestreet-origin "js-build-tools" version
- "0r8z4fz8iy5y6hkdlkpwf6rk4qigcr3dzyv35585xgg2ahf12zy6"))
- (native-inputs
- `(("oasis" ,ocaml-oasis)
- ("ocamlbuild" ,ocamlbuild)
- ("opam" ,opam)))
- (build-system ocaml-build-system)
- (arguments janestreet-arguments)
- (home-page "https://github.com/janestreet/js-build-tools")
- (synopsis "Collection of tools to help building Jane Street Packages")
- (description "This package contains tools to help building Jane Street
-packages, but can be used for other purposes. It contains:
-@enumerate
-@item an @command{oasis2opam-install} tool to produce a @file{.install} file
-from the oasis build log
-@item a @code{js_build_tools} ocamlbuild plugin with various goodies.
-@end enumerate")
- (license license:asl2.0)))
-
(define-public ocaml-cppo
(package
(name "ocaml-cppo")