summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-12-28 22:10:06 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-12-30 14:25:51 +0100
commit662307c30a462d98cb1b16a6c5de208d18adce71 (patch)
tree7026b4c61cab34f3c24a6ac5e0061616a54c2ba2 /gnu/packages/ocaml.scm
parent55c2851a19af470a19bdaf1539c161bf63a8465a (diff)
downloadguix-patches-662307c30a462d98cb1b16a6c5de208d18adce71.tar
guix-patches-662307c30a462d98cb1b16a6c5de208d18adce71.tar.gz
gnu: Add ocaml-parsexp.
* gnu/packages/ocaml.scm (ocaml-parsexp): New variable. (ocaml4.07-parsexp): Inherit from ocaml-parsexp. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 762784a0dd..2ba1dd90e5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4066,28 +4066,19 @@ that was developed by Jane Street, the largest industrial user of OCaml.")
(arguments `(#:tests? #f)) ; no tests
(properties '()))))
-(define-public ocaml4.07-parsexp
+(define-public ocaml-parsexp
(package
- (name "ocaml4.07-parsexp")
- (version "0.11.0")
+ (name "ocaml-parsexp")
+ (version "0.14.0")
(home-page "https://github.com/janestreet/parsexp")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append home-page ".git"))
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1nyq23s5igd8cf3n4qxprjvhbmb6ighb3fy5mw7hxl0mdgsw5fvz"))))
+ (janestreet-origin "parsexp" version
+ "158znj19dvfdcwsgzs3rdhxpj1g4aw0d4nkfr8c05bahf0lnshlb"))
(build-system dune-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
(inputs
- `(("ocaml-sexplib0" ,(package-with-ocaml4.07 ocaml-sexplib0))))
+ `(("ocaml-sexplib0" ,ocaml-sexplib0)
+ ("ocaml-base" ,ocaml-base)))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-parsexp))))
(synopsis "S-expression parsing library")
(description
"This library provides generic parsers for parsing S-expressions from
@@ -4116,6 +4107,17 @@ s-expressions from files or other external sources, you should use
parsexp_io.")
(license license:expat)))
+(define-public ocaml4.07-parsexp
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-parsexp)
+ (name "ocaml-parsexp")
+ (version "0.11.0")
+ (source
+ (janestreet-origin "parsexp" version
+ "11a30zkfgbi6pb4whq22k1zc8ghdp9bwxl5s5cdlmx1z8s4yxsf0"))
+ (properties '()))))
+
(define-public ocaml4.07-sexplib
(package
(name "ocaml4.07-sexplib")
@@ -4138,7 +4140,7 @@ parsexp_io.")
#:dune ,ocaml4.07-dune))
(propagated-inputs
`(("ocaml-num" ,(package-with-ocaml4.07 ocaml-num))
- ("ocaml-parsexp" ,ocaml4.07-parsexp)
+ ("ocaml-parsexp" ,(package-with-ocaml4.07 ocaml-parsexp))
("ocaml-sexplib0" ,(package-with-ocaml4.07 ocaml-sexplib0))))
(synopsis
"Library for serializing OCaml values to and from S-expressions")