summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:38:32 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-31 21:34:53 +0100
commit5d08f98d3e9253037a82522940a5a1496bc69b74 (patch)
tree11980867e353d8aef61a7fb2c035561d315d0126 /gnu/packages/ocaml.scm
parent59ae241f7189252c72394fae2e2b85ca61b72755 (diff)
downloadguix-patches-5d08f98d3e9253037a82522940a5a1496bc69b74.tar
guix-patches-5d08f98d3e9253037a82522940a5a1496bc69b74.tar.gz
gnu: Add ocaml-base64.
* gnu/packages/ocaml.scm (ocaml-base64): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 28c6ab34fa..0128337663 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1696,3 +1696,35 @@ without a complete in-memory representation of the data.")
(description "Client-side URL transfer library, supporting HTTP and a
multitude of other network protocols (FTP/SMTP/RTSP/etc).")
(license license:isc)))
+
+(define-public ocaml-base64
+ (package
+ (name "ocaml-base64")
+ (version "2.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/mirage/ocaml-base64/"
+ "releases/download/v" version "/base64-"
+ version ".tbz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1p45sawchmrkr22gkmydjc4ary23pisp58zsnb7iq7d82nxs1lfq"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:build-flags (list "build" "--tests" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("topkg" ,ocaml-topkg)
+ ("opam" ,opam)
+ ("rresult" ,ocaml-rresult)
+ ("bos" ,ocaml-bos)
+ ("alcotest" ,ocaml-alcotest)))
+ (home-page "https://github.com/mirage/ocaml-base64")
+ (synopsis "Base64 encoding for OCaml")
+ (description "Base64 is a group of similar binary-to-text encoding schemes
+that represent binary data in an ASCII string format by translating it into a
+radix-64 representation. It is specified in RFC 4648.")
+ (license license:isc)))