summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:23:00 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:16:52 +0200
commit5b61a1472b998c39b069e9a557c3029e1351d0a7 (patch)
tree104478af94747cdccb34243aad9509fd482fc766 /gnu/packages/ocaml.scm
parent3649c56a5f23501a5bb3418dc6047b71d494f0fa (diff)
downloadguix-patches-5b61a1472b998c39b069e9a557c3029e1351d0a7.tar
guix-patches-5b61a1472b998c39b069e9a557c3029e1351d0a7.tar.gz
gnu: Add ocaml-syntax-shims.
* gnu/packages/ocaml.scm (ocaml-syntax-shims): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b378708844..4f94273695 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6627,3 +6627,28 @@ exposed the intrinsics properly, the compiler doesn't have any fast blits
between Bigstrings and other string-like types. @code{bigstringaf} provides
these missing pieces.")
(license license:bsd-3)))
+
+(define-public ocaml-syntax-shims
+ (package
+ (name "ocaml-syntax-shims")
+ (version "1.0.0")
+ (home-page "https://github.com/ocaml-ppx/ocaml-syntax-shims")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l1i8z95qgb0lxlrv3yb5nkp391hqsiyi4r91p12k3xmggqixagf"))))
+ (build-system dune-build-system)
+ (properties
+ `((upstream-name . "ocaml-syntax-shims")))
+ (synopsis
+ "Backport new syntax to older OCaml versions")
+ (description
+ "This packages backports new features of the language to older
+compilers, such as let+.")
+ (license license:expat)))