summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-01-21 00:39:32 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-01-21 01:12:26 +0100
commit5aa573d8c796e50b2f1c4283f68b0f1a27cd4280 (patch)
tree109516374e5329854cc2a0ea8319ade74481e1dc /gnu/packages/ocaml.scm
parent16829d3b8a795d6a4bef32bfab1f10be2f466f23 (diff)
downloadguix-patches-5aa573d8c796e50b2f1c4283f68b0f1a27cd4280.tar
guix-patches-5aa573d8c796e50b2f1c4283f68b0f1a27cd4280.tar.gz
gnu: ocaml-markup: Update to 0.8.2.
gnu/packages/ocaml.scm (ocaml-markup): Update to 0.8.2.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0fc4a24172..31e200f3d5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5063,7 +5063,7 @@ the full Core is not available, such as in Javascript.")
(define-public ocaml-markup
(package
(name "ocaml-markup")
- (version "0.8.1")
+ (version "0.8.2")
(home-page "https://github.com/aantron/markup.ml")
(source
(origin
@@ -5074,14 +5074,20 @@ the full Core is not available, such as in Javascript.")
(file-name (git-file-name name version))
(sha256
(base32
- "0gzdjfnkv56vhmpvi9xpv1p05z50y55izhn156bkmb35s6izxds3"))))
+ "13zcrwzjmifniv3bvjbkd2ah8wwa3ld75bxh1d8hrzdvfxzh9szn"))))
(build-system dune-build-system)
+ (arguments
+ `(#:package "markup"))
+ (inputs
+ `(("libev" ,libev)))
(propagated-inputs
`(("ocaml-bisect-ppx" ,ocaml-bisect-ppx)
("ocaml-uchar" ,ocaml-uchar)
("ocaml-uutf" ,ocaml-uutf)
("ocaml-lwt" ,ocaml-lwt)))
- (native-inputs `(("ocaml-ounit" ,ocaml-ounit)))
+ (native-inputs
+ `(("ocaml-ounit" ,ocaml-ounit)
+ ("pkg-config" ,pkg-config)))
(synopsis "Error-recovering functional HTML5 and XML parsers and writers")
(description "Markup.ml provides an HTML parser and an XML parser. The
parsers are wrapped in a simple interface: they are functions that transform