summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:22:46 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:16:22 +0200
commit5a4acc53311c7013a2afeb5ce7460e2aa24a4c2b (patch)
treed8f5c9fe2ba5e78cc2026bb291a46aa06b628b10 /gnu/packages/ocaml.scm
parent0f62ea0774fee735a97b63a1d2dc9397cc21908b (diff)
downloadguix-patches-5a4acc53311c7013a2afeb5ce7460e2aa24a4c2b.tar
guix-patches-5a4acc53311c7013a2afeb5ce7460e2aa24a4c2b.tar.gz
gnu: ocaml-ctypes: Make ocaml-integers a propagated input.
* gnu/packages/ocaml.scm (ocaml-ctypes)[propagated-inputs]: Add ocaml-integers. [inputs]: Remove ocaml-integers. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cf31c2eae7..9e163994d9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3862,11 +3862,11 @@ long and size_t whose sizes depend on the host platform.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
- `(("bigarray-compat" ,ocaml-bigarray-compat)))
+ `(("bigarray-compat" ,ocaml-bigarray-compat)
+ ("integers" ,ocaml-integers)))
(inputs
`(("libffi" ,libffi)
("ounit" ,ocaml-ounit)
- ("integers" ,ocaml-integers)
("lwt" ,ocaml-lwt)
("topkg" ,ocaml-topkg)
("opam" ,opam)))