summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authoraecepoglu <aecepoglu@fastmail.fm>2021-01-11 23:55:33 +0300
committerJulien Lepiller <julien@lepiller.eu>2021-01-12 15:02:11 +0100
commit564cbfd99fd9d5bd462b33edb2af071ca3a4a5a1 (patch)
tree1572bcce968a31dd8c16c9f43bd4cdeff4b84fae /gnu/packages/ocaml.scm
parentb6529e189688ac8bc17c11cf24304fc554f5cb9b (diff)
downloadguix-patches-564cbfd99fd9d5bd462b33edb2af071ca3a4a5a1.tar
guix-patches-564cbfd99fd9d5bd462b33edb2af071ca3a4a5a1.tar.gz
ocaml: Add ocaml-ocp-index.
* gnu/packages/ocaml.scm (ocaml-ocp-index): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7528e9d5fe..4294d25efd 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2401,6 +2401,39 @@ This package includes:
fault-tolerant and approximate parsing.
@end itemize")
(license license:lgpl2.1)))
+
+(define-public ocaml-ocp-index
+ (package
+ (name "ocaml-ocp-index")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OCamlPro/ocp-index")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08r7mxdnxmhff37fw4hmrpjgckgi5kaiiiirwp4rmdl594z0h9c8"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:package "ocp-index"))
+ (propagated-inputs
+ `(("ocaml-ocp-indent" ,ocaml-ocp-indent)
+ ("ocaml-re" ,ocaml-re)
+ ("ocaml-cmdliner" ,ocaml-cmdliner)))
+ (native-inputs
+ `(("ocaml-cppo" ,ocaml-cppo)))
+ (home-page "https://www.typerex.org/ocp-index.html")
+ (synopsis "Lightweight completion and documentation browsing for OCaml libraries")
+ (description "This package includes only the @code{ocp-index} library
+and command-line tool.")
+ ;; All files in libs/ are GNU lgpl2.1
+ ;; For static linking, clause 6 of LGPL is lifted
+ ;; All other files under GNU gpl3
+ (license (list license:gpl3+
+ license:lgpl2.1+))))
(define-public ocaml-ocurl
(package